Cannot install EndeavourOS

Hello everyone! This is my first post on this forum and unfortunately I’m having a problem with installing EndeavourOS. I hope you can help me.

Installer logs:

installer log from live session:

cat /var/log/endeavour-install.log | eos-sendlog

[liveuser@eos-2023.05.28 ~]$ cat /var/log/endeavour-install.log | eos-sendlog
cat: /var/log/endeavour-install.log: No such file or directory
==> eos-sendlog: warning: nothing to send.

Hardware information:

inxi -Fxxc0z --no-host | eos-sendlog

Boot log:

journalctl -b -0 | eos-sendlog

I took a quick look at the logs and it says something about pacstrap not being able to downloading gcc libraries, kernel and a bunch of other stuff. What should I do?

That looks like a network issue. It is failing to download the packages.

I would reboot and try again. If it still fails, you could try an offline install.

I’m not sure what fixed the issue because I tried two things at a time. I have chosen the other wired network driver than the default and at the same time I shared my phone’s mobile network with my PC. After that everything worked.

It is strange that I had this problem only with EndeavourOS, because the same day I also tried to install other distros and had no problems. I guess something changed in my home network. Who knows.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.