Cannot install EndeavourOS on ASUS ROG Strix Scar G533qr Laptop

Hello all,

I’ve been attempting (with no success) to install EndeavourOS in a duel-boot configuration with Windows 11

General Laptop Specs:

AMD Ryzen 9 9000HX with Radeon Graphics

Nvidia RTX 3070m: Optimus

32 gigs of RAM

1 TB Nvme

BIOS version: 331

The behavior I’m seeing is that at random points during the installation process my system will lock-up requiring a power cycle. Due to when these lockups occur and the fact I have to power cycle, I am unable to capture any logs and what’s worse no error messages or alerts of any kind display.

What happens in Windows 11 pro? Nothing, the system appears to functioning as expected.

Steps I’ve taken thus far:

  1. Disabled Secure Boot in Bios
  2. Disabled Fast Boot in Bios and in Windows
  3. Set GPU to “Hybrid” Mode within ASUS Armory Crate
  4. Set Windows power plan to Balanced

I’ve followed the recommendations for dual-booting Linux and Windows at

Finally, my working theory is that the installation process is bombing because of the power management features of the CPU (that could be wrong however) I’m grasping at straws at this point. Any assistance, ideas, or words of encouragement are welcome and needed.
Many Thanks!

Hi and welcome to the forum @Varanus1138

This is about all I can do at this point for you, I would say don’t give up just yet. I’m sure someone will be able to point you in the correct direction.

Have you tried selecting the “offline” install option? On some occasions, this has helped me overcome odd issues.

Hey thanks for getting back to me.
Unfortunately offline install yields the same results.

Just guessing, but it might be because of the GPU settings or drivers.
When you boot the installer, which menu item did you select?
What GPU modes are supported by the machine other than “Hybrid”?

I have a fairly similar system (rog strix g17) and never had any of these issues :thinking:

When you boot from the installation usb you should be able to select between booting off open source or proprietary gpu drivers, see if you get different results based on which you pick.

this is a bit of a nutty option, but you could try removing your ssd from the laptop, plugging it into another pc, installing endeavouros there, then moving it back to the laptop.

I have tried the Default, Nvidia, and Fallback boot options with similar results. Although when using the Fallback option I usually get as far as the graphical Calamares installer before the lock-up occurs.Keep in mind, when the system freezes it always requires a power cycle.
To answer your other question, my system does support Radeon graphics mode (Eco), Hybrid mode, and Performance (Nvidia Graphics).
Performance mode on this particular machine is a little odd as it only achieved if you plug in a monitor via the USB-C port.
EndeavourOS is the only distro that besides Nobara that engages my external monitor during installation (I assume because of the driver package). But I’ve tried to install from all three modes with the same result.

Is your ROG Strix g17 Intel or AMD based?
Also your suggestion of trying to install to the HD on another machine is brilliant! Unfortunately I don’t have another machine to move the NVME drive to. :frowning:

Did you try without the external monitor?

Can you install in this mode?
Nvidia driver can be installed later.

Yeah, I’ve tried with, and without the external monitor. Same results…same blasted results.
I’m considering appealing to the OS Gods…anyone know what sacrifices they accept?

I’ve tried installing with only the CPU based Radeon graphics with the same result.
What’s so frustrating about my machine is that none of these settings can be made within the Bios itself, I have to use ASUS’s software to change these modes within Windows.

If I remember correctly, one can toggle the logs (terminal output) already in the Calamares installer while installation is going on to follow the process. Perhaps that could show some errors or the like.

How did you create the live usb?

If it were me I would create a new live usb possibly re downloading the ISO also. I would use etcher from Windows to create the live usb. Make sure that the fast start up feature in Windows under power management is turned off. Then i would make sure you clear the secure boot keys first and then disable secure boot, as well as CSM and fast boot in the Bios.

1 Like

Live CD has been created on a few occasions with Etcher and Fedora Media Writer.
Windows Fast Start has been disabled.
Bios Fast Start has been disabled
Secure Boot has been disabled. (Have not cleared the secure boot keys as I’ve not gotten a definitive answer as to what would happen if I did.)
This Bios on my machine has very few configuration options which I’ve read is fairly common on AMD systems with TPM 2.0

1 Like

I wonder if you try using nomodeset nouveau.modeset=0 kernel parameter to disable the nvidia on boot. Maybe try this booting on the default menu for the live usb. :thinking:

I gave it a shot, unfortunately same result. A hard lock once the graphical UI started.
Every instinct tells me this is a hardware problem, but without consistent behavior and a perfectly functional Windows 11 installation I’m at a loss.

Very new hardware so I’m not sure. Have you tried any other distro’s?

LiveCD? That does not make sense, your laptop doesn’t even have a dvd drive! I take it you mean liveusb. I’ve never heard of etcher or fedora media writer, but what I always do to create live usbs or bootable installers from windows is use Rufus.

From Linux I find dd most reliable. Follow the instructions in here:

Also I would make sure that your downloaded iso is not corrupted, on the download page ( ) you can see the sha512sum, you can then run sha512sum on the iso to make sure it matches the sum the site tells you it should be, if it doesn’t, the download was corrupted.

And yes i am on amd/nvidia system too.

If you think it’s power management issues causing the issue (A bit of a stretch to be honest) you can force your cpu governor to performance mode as well to rule that out.

Really? OP has already been asked to re download the ISO and try another live usb. Rufus doesn’t always work for many users for what ever reason. Nothing wrong with Etcher or Fedora Media Writer. Both are good and do work.