Cannot install - but perhaps more of an Arch issue than EOS?

[Note: I’d been successful previously in installing EOS on this MacMiniHD … so I know it was once possible]

Trying to install EOS - or even just Arch - on my 2011 MacMini. Short version:

Cannot get (any) ISO image to properly load up.

Have tried latest EOS, Arch, Kali, Manjaro ISOs, all fail to get live image up and running. Tried with or without Ventoy on a 16g SD card and 8g thumbdrive - no difference.

Longer version:

Trying EOS, Kali, Majaro ISOs >> Just hangs with a blank screen.

At one point I was able to see an EOS grub menu but all selections thereafter go blank … including “EFI Shell” selection (and thumbdrive activity light goes dormant).

Trying Arch ISO >> I can get Grub v2.04 screen, selecting “Arch Linux Install medium (x86_64, UEFI)” then I get:

Downloading kernel...
Downloading initrd...

… which seems promising, but shortly thereafter I repeatedly get a bunch of mmc0:sdhci: register dump hexadecimals with the final one being
ADMA Err: 0x00000001 | ADMA Ptr: 0x00000000000000

and then:

Timeout waiting for hardware cmd interrupt” screen error. This repeats over and over approx every 10 seconds.

If I remove the SD card or thumb drive ISOs and just power up, I can reach grub rescue — but having followed Arch wiki guidance to ls and identify a boot partition, I cannot find any existing partition that has a recognizable file structure to target for installing/repairing grub from there. Each and every one is Filesystem is unknown.

Have even wiped MacMini’s HD using Apple’s disk utility willing to start from scratch. No change in outcome.

Seems I’ve somehow managed to brick this MacMini.
Any suggestions?

When I fail to install from Ventoy–it happens a lot and it happened to me reinstalling Endeavour recently–then Plan B is burn a USB stick.

My computer always sees the USB stick.
Plan B did not work for you. What I think you have to do is get your bios OUT of uefi-only mode and set boot to “uefi and legacy”----works for me…
…but unsure how a Mac works in that respect, to be honest. At least you loaded it part-way before you got sandbagged. switching to legacy and/or grub on the install media is a cheat I’ve used.

1 Like

Many thanks for the suggestions! Unfortunately Apple makes life very difficult to achieve much of what you’ve shared - there’s no BIOS-equivalent access at the power-on stage.

I will dig a bit deeper to see if there’s a way to sneak in to achieve any of this.

Apples makes some nicely designed hardware, and then makes it near impossible to leave their well-fenced garden. Argh!

1 Like

Lots of Mac people here, hang loose. There’s a way to beat the well-fenced garden it’s just that someone else knows how :slight_smile: right now

1 Like

Thanks for the encouragement.

I’ve got a 2019 iMac running EOS/i3wm beautifully as my daily driver, plus a 2011 MacBookPro laptop by its side for travel.

But it’s this MacMini that is misbehaving poorly … can’t even reinstall the OSX “Sierra Whatever” after I tried a factory cleanup… Apple has apparently abandoned ship.

Am now resorting to perusing directories/files via Terminal in OSX Recovery mode to see if I can find anything to establish a toe-hold onto and climb from there :roll_eyes:

well this title says everything (it can’t be done?):

but then there’s this:

just typed ‘mac mini’ into search function. there’s interesting reading

Interesting indeed. I believe my old MacMini is 64 bit… but perhaps I’m mistaken?

The rEFInd idea is intriguing. Having recently managed to finally get it OFF of my 2019 iMac (with great help from @ddnn and others here) and make my way back to GRUB, rEFInd might turn out to be the (ironic) fix to this old Mini’s travails. :thinking:

yes, I forgot about refind, too.

Try “zapping” the PRAM to see if it makes any difference.

1 Like

I don’t know if there’s a difference between the 2011 and late 2014 MacMini or not. But I’ve had great success with my late 2014 MacMini installing various distros. Siduction, openSUSE, Fedora, Arch, and finally EndeavourOS all installed fine and were as usable as if I installed on a PC or laptop.

Thanks for the suggestion! Gave it a try - reset/flashed the NVRAM per Apple’s instruction. Apparently not making any difference.

Tried reinstalling the OS from Apple website … downloaded for 4 hours … eventually started trying to reinstall MacOS … and failed!

Followed the link provided to, and Apply says that page is no longer available. Sheesh.

Okay, now I’m on to trying rEFInd. No luck yet. Details to follow. :roll_eyes: