Cannot get school wifi to connect

Endeavour is having authentication issues connecting to my schools wifi (it works fine at home), when connecting it will endlessly ask for username/password even though I know for certain they are correct. I’ve checked the settings compared to my android device (which does work) and they are both the same. Other solutions I’ve tried online have not worked so far.

*****-RADIUS.nmconnection

[connection]
uuid=a9298a27-5d06-457d-88af-cc63377a7d13
type=wifi
interface-name=wlan0
permissions=

[wifi]
mac-address-blacklist=
mode=infrastructure
ssid=*****-RADIUS

[wifi-security]
key-mgmt=wpa-eap // Matches android (android has IEEE8021X at the end but I believe this is fine)

[802-1x]
domain-suffix-match=\s
eap=peap; // Matches android
identity=********** // Matches android
password=********** // Matches android
phase2-auth=mschapv2 // Matches android

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]

As I’m a noob I’m not sure if there are anything else I might need to provide but I am willing to provide anything relevant to the issue.

It has most likely to do with the wifi security settings, make sure you check in wifi settings gui again and use the school wifi recommendation.

Also, if using Network Manager, remember to click “Save” in the WiFi Security section. Otherwise it will keep asking for the password.

Have you check the password protocol of your school?
I guess at your home is WPA & WPA2 Personal, maybe your school use WPA & WPA2 entreprise!!

badplugin.

I’ve already checked the settings compared to my android device, the settings I have are all correct but it still has a authentication error.

I don’t use presently an android device, but as I recall the settings on you phone have less options than on linux.

To solve your problem you need to ask your school IT admin the exact wifi options you need. We cant help troubleshoot from here with the information given.

1 Like

Welcome to the purple :enos: side of Linux. From the problem, you’re describing it seems your WiFi credentials not getting authenticated correctly. The problems might be due to one side is having issues with deciphering the password or the WiFi login credentials. That’s why you’re getting connected and then getting kicked and asked for the password again.

It’s best to go to your school’s IT admin and get that resolved. As @Zircon34 said in the post above mine. We can’t help you to resolve this. Best person who can do this is you shools IT god (IT Admin).

I would say that you need to set the right security mode.

Edit: As mentioned in the other posts. Check with the schools IT dept what the settings need to be.

1 Like

As i’ve said already the security mode matches that of my android device, I doubt changing it from what I already have will do anything.

It shouldn’t be the same as an android device. Check with your schools IT dept for the correct settings needed.

1 Like

Guess I will ask them then although my hopes are low, they have told people off for using macs instead of windows, I doubt they will very much like linux which is why i’ve been holding off asking them.

1 Like

Perhaps don’t specify except to say ‘computer’ (as opposed to Android) - and see what you get told. Always worth a try… :grin:

Hey, it’s not your fault if they make inaccurate assumptions… avoiding them yourself is what you’re there to learn, right?

1 Like