Cannot get installed on new laptop

I cannot get into the installation GUI on my new ASUS ROG Strix Laptop (G614JVR).

The installation media works well with my two old computers.

However, with my new Laptop, I get a lot of [FAILED] messages. Some examples are:

  • Failed to start Bluetooth service
  • Dependency failed for Network Manager
  • Failed to start D-Bus System Message Bus
  • Failed to start Restore /run/initramfs on shutdown
  • SQUASHFS error: Failed to read block 0x2c0974b: -5

The installation media is good since I can get it to boot on other computers. Googling for the SQUASHFS, all tells me it is a media problem though.

So, I am guessing this is some problem related to missing driver support.

I am trying to install Endeavouros because someone told me Ubuntu has kernel lag and the driver for GPU is not so up-to-date.

After a few days of trying on my other computer, I can say Arch-based is in some ways better. I can install packages without the need to care about many dependency problems. However, this real experience of installation on my laptop is telling me Ubuntu is the better. I got Ubuntu 23.10 or 23.04 boot without any problems on my laptop.

hey welcome here :enos:
i do not think this is a driver issue looks more like System firmware has secureboot enabled? W edo not support secureboot, ubuntu does.

I have secureboot disabled.

1 Like

this one is a restriction on boot or an issue with the used media or used port. and if it works just fine on other systems it looks like a restriction or setting in system firmware or boot option there causing the issue.
How you created the installer media?

I have tried ventoy and rufus. The ventoy usb drive I used have both ubuntu and enos, and I used it to install enos on my Desktop computer successfully. The rufus usb drive is also tried. I can get into the GUI on another computer. Both ventoy and rufus don’t work on my laptop and have this SQUASHFS error. The available two physical USB type-A ports are both tried. I didn’t check the type-C ports though.

The BIOS settings related I think is VMD (disabled), Secureboot (disabled) and the GPU setting. The available GPU setting in BIOS is dGPU only and dynamic. Both tried, and I can only switch to eGPU only through Armory Crate in Windows which I also tried.

All boot options of enos are tied of course.

Rufus in dd mode?
And Ventoy is updated to latest version on the stick?
And some Firmwares have two places to set up boot parameters some have extra for usb drives/media … Could be also CSM legacy option is on for USB or fastboot is enabled if windows is also installed.

Finally, I got it to boot with Ventoy. I have no idea why the two USBs working for Desktop PCs won’t work for my laptop. I managed to find an old USB drive that has Ventoy 1.0.77 installed and I upgraded to 1.0.97. Using that USB drive, it works.

All USBs are not created equal…

Ventoy is not the best to use. :wink:

Our ISO does not need any fancy tool at all:

1 Like