Cannot enter kde desktop after entering password

Hello, i couldn’t enter my KDE desktop after rebooting.
the login window is nomal as usaul, but when a enter the password, it just go black screen with a mouse icon(mouse is working), I am just setting my zsh and tmux(still have some problem)

I can enter tty mode.
and I have try this cmd line to restart the plasma

startx /usr/bin/startplasma-x11 

It worked, but i need to do everytime I reboot my system.
and I get the log with Log tool.

#################### inxi -Fxxc0z ########################

  Kernel: 5.16.11-arch1-2 x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: KDE Plasma 5.24.2
    tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A15 FA506IV_FA506IV v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FA506IV v: 1.0 serial: <superuser required> UEFI: American Megatrends
    v: FA506IV.316 date: 03/12/2021
  ID-1: BAT1 charge: 38.3 Wh (100.0%) condition: 38.3/48.1 Wh (79.7%) volts: 12.6 min: 11.7
    model: ASUS A32-K55 serial: N/A status: Full
  Device-1: hidpp_battery_0 model: Logitech Marathon Mouse/Performance Plus M705
    serial: <filter> charge: 55% (should be ignored) status: Discharging
  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
    rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 8 MiB
  Speed (MHz): avg: 1725 high: 2966 min/max: 1400/2900 boost: enabled cores: 1: 1788 2: 1514
    3: 1884 4: 1795 5: 1560 6: 1538 7: 1518 8: 1594 9: 1725 10: 1650 11: 1524 12: 1608 13: 1598
    14: 1644 15: 1699 16: 2966 bogomips: 92666
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: ASUSTeK driver: nvidia v: 510.54 pcie:
    speed: 2.5 GT/s lanes: 8 ports: active: none empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:1f15
  Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel pcie: speed: 16 GT/s lanes: 16
    ports: active: HDMI-A-1,eDP-1 empty: none bus-ID: 06:00.0 chip-ID: 1002:1636
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-4:4
    chip-ID: 13d3:56a2
  Display: server: X.Org v: compositor: kwin_x11 driver: X: loaded: amdgpu,ati,nvidia
    unloaded: modesetting,radeon alternate: fbdev,nouveau,nv,vesa gpu: amdgpu display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 3840x1528 s-dpi: 96
  Monitor-1: HDMI-A-0 mapped: HDMI-A-1 pos: primary,top-right model: Dell SE2416H res: 1920x1080
    dpi: 93 diag: 604mm (23.8")
  Monitor-2: eDP pos: bottom-l res: 1920x1080 dpi: 142 diag: 395mm (15.5")
  OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.11-arch1-2 LLVM 13.0.1) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: speed: 2.5 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:10f9
  Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: speed: 16 GT/s lanes: 16 bus-ID: 06:00.1 chip-ID: 1002:1637
  Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A pcie: speed: 16 GT/s
    lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2
  Device-4: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    speed: 16 GT/s lanes: 16 bus-ID: 06:00.6 chip-ID: 1022:15e3
  Sound Server-1: ALSA v: k5.16.11-arch1-2 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.47 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168
    v: 8.049.02-NAPI pcie: speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave
    driver: rtw_8822ce v: N/A pcie: speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:c822
  IF: wlan0 state: up mac: <filter>
  Device-3: Realtek RTL8152 Fast Ethernet Adapter type: USB driver: r8152 bus-ID: 3-2:2
    chip-ID: 0bda:8152
  IF: enp6s0f3u2 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 5-1:2
    chip-ID: 13d3:3548
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled rfk-block: hardware: no
    software: no address: see --recommends
  Local Storage: total: 1.84 TiB used: 558.89 GiB (29.6%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G1B0C-00S6U0 size: 465.76 GiB
    speed: 15.8 Gb/s lanes: 2 serial: <filter> temp: 47.9 C
  ID-2: /dev/nvme1n1 vendor: Kingston model: OM8PCP3512F-AB size: 476.94 GiB speed: 31.6 Gb/s
    lanes: 4 serial: <filter> temp: 34.9 C
  ID-3: /dev/sda vendor: Western Digital model: WDS100T2B0A-00SM50 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-4: /dev/sdb type: USB vendor: Toshiba model: TransMemory size: 14.45 GiB serial: <filter>
  ID-1: / size: 97.87 GiB used: 12.05 GiB (12.3%) fs: ext4 dev: /dev/nvme1n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1
  ID-3: /home size: 330.29 GiB used: 11.18 GiB (3.4%) fs: ext4 dev: /dev/nvme1n1p5
  ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme1n1p3
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: amdgpu temp: 41.0 C
  Fan Speeds (RPM): cpu: 2200
  Processes: 355 Uptime: 14m Memory: 30.84 GiB used: 2.98 GiB (9.7%) Init: systemd v: 250
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1387 Client: KDE Plasma v: 5.24.2
  inxi: 3.3.13

by the way, the log generated by ‘journalctl -b -0’ seems too long and i can upload here.
what else log should I offer?


Maybe check this out to see if it helps.

1 Like

What was changed in your system before this happens? Check recently upated packages (/var/log/pacman.log)
After a fresh (re)boot, try to login from SDDM. When/if it fails, login from TTY and before you run plasma command, grab login messages in a file.

journalctl --user -b -p3 --no-pager --no-hostname > loginfailed.log

Then start plasma and repeat

journalctl --user -b -p3 --no-pager --no-hostname > logintty.log

Post log files ($HOME/loginfailed.log and $HOME/logintty.log)

Also, try to relogin after you have disconnected the external monitor.

1 Like

I don’t know if you did this, but go to tty and reinstall plasma. Maybe some update broke a dependency for plasma. Just type sudo pacman -S plasma and then reboot. And make sure you use the plasma x11 option.

1 Like

I just clean up the ~/.xprofile and this problem seems to be solved.
(I added “source ~/.zshrc” before)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.