Cannot enable second screen on arch linux KDE 6

Hello, I have been trying to find the solutions for hours and I cannot find it, basically when I go in the kscreen manager setting and enable my second screen it auto disable and display nothing, anyone knows how to fix this?

Did you disable it at some point?

Are you able to click on the enable checkbox? If you are have you made sure to apply the setting after?

@Untreated8054, Have you tried Super + P ?

sorry for the late reply I was repairing my pc which is why I couldn’t respond. I tried super + p without success my second screen does not show no matter what

I clicked on enabled as soon I click “apply” it auto disable itself no ideas how to fix this. Btw sorry for the late reply I was repairing my pc which is why I couldn’t respond.

It just auto disable itself sadly I can’t even enable it.

sorry for the late reply I was repairing my pc which is why I couldn’t respond.

No problem. Can you try a different cable?

Click Enable, then try moving that MSI monitor. If they overlap it might prevent activation?

Well I tried connecting my second hdmi cable to my first gpu so both screen use the same gpu and it works and I can enable it but it does not works if I connect it to my second gpu. Any ideas how to fix it?. I did noticed some issues like steam proton crashing my game like cs2 but I think its better if I make another thread for it

It seems to be an issue with connecting 1 cable to gpu # 1 and gpu #2 like mentionned above otherwise it works

Ahh dual GPUs, we should have asked for hardware specs days ago. What kind of system are you running?

Run inxi -Fxxx in the terminal and report that info here.

1 Like

System:
Host: MicrosoftMikeSecretHentaiStash Kernel: 6.9.3-zen1-1-zen arch: x86_64
bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A wm: kwin_x11 vt: 2 dm: SDDM
Distro: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: A520M H serial:
uuid: UEFI: American Megatrends LLC. v: P2.40
date: 08/09/2023
CPU:
Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP smt: enabled
arch: Zen 3+ rev: 2 cache: L1: 768 KiB L2: 6 MiB L3: 64 MiB
Speed (MHz): avg: 4442 high: 4443 min/max: 2200/4950 boost: enabled cores:
1: 4442 2: 4442 3: 4442 4: 4442 5: 4442 6: 4442 7: 4442 8: 4442 9: 4441
10: 4442 11: 4443 12: 4442 13: 4442 14: 4442 15: 4442 16: 4442 17: 4442
18: 4442 19: 4442 20: 4442 21: 4442 22: 4442 23: 4442 24: 4442
bogomips: 177271
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
Device-1: NVIDIA AD107 [GeForce RTX 4060] vendor: ASUSTeK driver: nvidia
v: 550.78 arch: Lovelace pcie: speed: 2.5 GT/s lanes: 4 ports: active: none
empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 04:00.0 chip-ID: 10de:2882
class-ID: 0300
Device-2: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate]
vendor: Micro-Star MSI driver: nvidia v: 550.78 arch: Ampere pcie:
speed: 16 GT/s lanes: 16 ports: active: none off: DP-4,HDMI-A-2
empty: DP-5,DP-6 bus-ID: 07:00.0 chip-ID: 10de:2489 class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x333mm (41.50x13.11")
s-diag: 1105mm (43.52")
Monitor-1: not-matched mapped: DP-0 pos: primary,left res: 2560x1440
hz: 240 dpi: 108 size: 600x330mm (23.62x12.99") diag: 685mm (26.96")
modes: N/A
Monitor-2: not-matched mapped: HDMI-0 pos: right res: 1920x1080 dpi: 80
size: 609x348mm (23.98x13.7") diag: 701mm (27.61") modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 1
drv: nvidia device: 4 drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia
x11: drv: nvidia inactive: wayland,device-2,device-3
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2
API: Vulkan v: 1.3.279 layers: 7 surfaces: xcb,xlib device: 0
type: discrete-gpu driver: nvidia device-ID: 10de:2882 device: 1
type: discrete-gpu driver: nvidia device-ID: 10de:2489
Audio:
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
speed: 8 GT/s lanes: 4 bus-ID: 04:00.1 chip-ID: 10de:22be class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
bus-ID: 07:00.1 chip-ID: 10de:228b class-ID: 0403
Device-3: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-4: Logitech Logitech G PRO X Gaming Headset
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 bus-ID: 1-3:2 chip-ID: 046d:0aaa class-ID: 0300
serial: 000000000000
Device-5: HP HyperX SoloCast driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 bus-ID: 3-4:4 chip-ID: 03f0:078b
class-ID: 0300
API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 9c:6b:00:08:e2:e8
Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:24fb
class-ID: 0280
IF: wlan0 state: down mac: be:3c:dd:c1:8c:77
Bluetooth:
Device-1: Intel Wireless-AC 3168 Bluetooth driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-9:3 chip-ID: 8087:0aa7
class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: see --recommends
Drives:
Local Storage: total: 4.15 TiB used: 71.27 GiB (1.7%)
ID-1: /dev/nvme0n1 vendor: Kingston model: SNVS1000GB size: 931.51 GiB
speed: 31.6 Gb/s lanes: 4 tech: SSD serial: 50026B7684D63750
fw-rev: S8442101 temp: 30.9 C scheme: GPT
ID-2: /dev/sda vendor: Fanxiang model: S101 1TB size: 953.87 GiB
speed: 6.0 Gb/s tech: SSD serial: AA000000000000004776 fw-rev: 6B0
scheme: MBR
ID-3: /dev/sdb vendor: Intel model: SSDSC2KW512G8 size: 476.94 GiB
speed: 6.0 Gb/s tech: SSD serial: BTLA8244004T512DGN fw-rev: 002C
scheme: MBR
ID-4: /dev/sdc vendor: Toshiba model: DT01ACA200 size: 1.82 TiB type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 tech: HDD rpm: 7200 serial: Y3BMNS8AS
scheme: GPT
ID-5: /dev/sdd model: USB DISK 3.0 size: 28.88 GiB type: USB rev: 3.2
spd: 5 Gb/s lanes: 1 tech: N/A serial: 07001BCA11A75D26 fw-rev: PMAP
scheme: MBR
Partition:
ID-1: / size: 914.83 GiB used: 71.14 GiB (7.8%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot size: 1022 MiB used: 128 MiB (12.5%) fs: vfat
dev: /dev/nvme0n1p1
Swap:
ID-1: swap-1 type: zram size: 4 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 69.0 C mobo: N/A gpu: nvidia temp: 45 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
Memory: total: 96 GiB note: est. available: 94.22 GiB
used: 12.53 GiB (13.3%)
Processes: 515 Power: uptime: 2h 36m states: freeze,mem,disk suspend: deep
wakeups: 0 hibernate: platform Init: systemd v: 255 default: graphical
Packages: 870 pm: pacman pkgs: 859 pm: flatpak pkgs: 11 Compilers:
gcc: 14.1.1 Shell: Bash v: 5.2.26 running-in: konsole inxi: 3.3.34

So 2 dedicated pcie Nvidia GPUs? you are sure the powersupply can handly this?
Propritary Nvidia Driver is installed but do you set DRM modesetting in early boot? you may are effected by some latest hickups with the RTX 4060 what could be the reason to not show display … what i said it does not get enough power.

yup my power supply is gold 1000w. it works on windows not linux

1000 Watts should not cause power issues indeed.

Propritary Nvidia Driver is installed but do you set DRM modesetting in early boot?

yup its there GRUB_CMDLINE_LINUX_DEFAULT=“loglevel=3 nvidia_drm.modeset=1”

edit: idk what happened but now it works, I had this setting for a while seems I forgot to rebuild grub and then rebooting, thank you!

Edit: Here is the command in grub in (GRUB_CMDLINE_LINUX_DEFAULT=): nvidia_drm.modeset=1

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.