Cannot copy or paste with keyboard shortcuts on terminal

On EOS terminal i cannot copy or paste via keyboard shortcut. if i type ctrl+v for example, it just turns into ^M.

Yes. You need to use ctrl+shift+c in the terminal because ctrl+c kills processes.

When i highlight text in the terminal and type ctrl+alt+c I get a ^C result on a new line. When i try to paste text with ctrl+alt+v nothing happens.

What am I doing wrong??


My fault, it is ctrl+shift+c. I do it subconsciously now.

1 Like

I use ctrl + insert to copy and shift + insert to paste


It’s interesting, you don’t even think about such a small thing, although I usually use the right mouse button menu for this purpose.

Try kitty - it can be set to use Ctrl-c&v, using copy_or_interrupt setting:

This worked for me!
Thank you @svepp

1 Like

@limotux there’s a thing even more easy
only highlight the text and push the middle mousekey at the place you want to drop it :innocent:


This is like magic for me. It worked as well! Much easier.
Thank you very much @colin

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.