Cannot connect to college's wifi network ( it does not use a CA cert )

Hello everyone.

I installed endeavour os again and I have a major issue that is not only in endeavour but on all rolling release distros that I tried. ( I tried arch, opensuse TW, endeavour, garuda, crystal, arxolinux, archlabs ). The issue is that I cannot connect to the WiFi of the university. I also tried with Ubuntu based distros but for some reason I Ubuntu and pop os managed to connect perfectly with no problems.

Here is some info about the WiFi connection:

it uses WPA/WPA2 enterprise

it does not need a CA cert

uses university username and password ( I put them correctly)

cannot connect when using arch based distros and opensuse TW but Ubuntu and pop os can connect to it with no issues

it is not a part of the eduroam systems.

Have a nice day Everyone

Is your password selected to “WPA/WPA2 enterprise” in the NetworkManger config ?


Sometimes it is best to ask your College or University IT dept what parameters are needed to connect.

I did, They told me that the settings I use are all right and that many american students that came to my college used ubuntu or ubuntu based distros and it worked perfectly. The issue is that I DO NOT WANT TO USE UBUNTU OR UBUNTU BASED DISTROS. So basically they did no actual good. I guess I am the only greek there that uses an arch based distro.

Well it should work but i know sometimes things don’t work when they should for one reason or another. I was able to connect with EndeavourOS in my Enterprise environment at the Schools but sometimes i did have issues where it didn’t want to connect also. But again changes happen in these environments frequently hence why i suggested checking with them first. Sometimes it’s the protocol being used or something else. :man_shrugging:

WPA/WPA2 enterprise mode seems correct.

Again verify your credentials such as login ID and password? That’s all i can suggest.

Just verified them and had the same issue, I even reseted the password, disabled the account and reenabled it. Works on pop os but not in endeavour.

Is it the same desktop on both?

I found myself in the exact same situation: college wpa2 wifi not working

By default, your system probably uses wpa_supplicant

Try installing iwd, reboot your system and see if you can connect to the college wifi. This fixed it for me

1 Like

I use gnome on both of them.

Have you tried using network manager from the terminal (nmcli) to connect and see if it spits out what the problem is?

1 Like

@dalto or @joekamprad, do you guys know how to solve this issue by any chance or something to try that we haven’t thought of?

iwd is installed by deafult in my laptop

IDK if it helps but here is the output of inxi -Na

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280 temp: 57.0 C
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 3.2 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1:2
    chip-ID: 0bda:8153 class-ID: 0000 serial: 7E1357
  Device-4: TP-Link UE300 10/100/1000 LAN (ethernet mode) [Realtek RTL8153]
    driver: r8152 type: USB rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    bus-ID: 2-2.4:5 chip-ID: 2357:0601 class-ID: 0000 serial: 000001

iwd was preinstalled. Tell me if you need anything else.

it says after the correct config: Connection activation failed

Was that it, no other output? Maybe journalctl will reveal some more info?