Cannot change `mem_sleep`

I am trying to get my laptop to use suspend to ram instead of suspend to idle. It should be possible, since when I cat /sys/power/mem_sleep it returns [s2idle] deep.
I should be able to change it by writing deep to the file, i.e. with echo deep | sudo tee -a /sys/power/mem_sleep, but this seems to have no effect.
(See, also this did work on another laptop that is also running endeavour.)

I’m running endeavour (obviously) with the i3 pre-configured version.
I’m not aware of any other programs that might be controlling this setting.

$ uname -r                                                                                                                                                                                                                  

I should note that it’s a razer laptop (blade 18), which seems to not have the best hardware support for linux.

Any ideas what’s going on or how I can fix it?

I just (16 days later) tried again it worked, insofar as the change in /sys/power/mem_sleep did take effect (haven’t tried whether it really draws less power during sleep).
I had not taken any specific action, so this was either fixed by rebooting or updating (unlike since I’m still on the same kernel release).

does that survive a reboot though ? (i.e., isn’t the setting reverted on next reboot?)

Sadly it is reset :frowning:

Any ideas on how to make this permanent?

As per the wiki

you can make the change permanent with the mem_sleep_default=deep kernel parameter.

I assume it should be sufficient.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.