Cannot build pamac-aur-git

Seems like pamac-aur-git does not build on my system. Related to Meson.
…/src/meson.build:7:0: ERROR: Invalid version of dependency, need ‘pamac’ [’>=11.1’] found ‘11’.

Stuck in Limbo
Thanks

I found the same thing yesterday. I installed pamac-aur instead for now at least.

1 Like

Most users are going to want to use the pamac-aur package as that one is the most stable overall.

3 Likes

Okay then – I’ll revert to pamac-aur.

New something was fishy when the git edition wouldn’t even build from Gitlab Pamac-Master …

I’ve always used the git version. Sometimes pamac-aur has had the same issue of not building because of needing updating. To me they both do the same thing so i don’t really have a problem using one or the other. :man_shrugging:

1 Like

I’m adding 20 yay’s to topic as the best fallback :star_struck: - Yay has never failed me!

Working on pamac-aur-git to see what is going on. Could be related to pamac 10.2.0 beta…

Looks like a new libpamac is needed: https://gitlab.manjaro.org/applications/libpamac/-/releases/11.1.0beta

3 Likes

So, here is some screenshots of pamac-aur-git 10.2.0beta. In french, sorry!

Full view:

Libpamac update:

Pamac 10.2.0beta:

Please, next time, just ask for some help related to pamac-aur-git. I’ll do my best to fix any problems asap.

1 Like

Okay… I didn’t know to ask you. I will switch mine back to git version as i usually do.

Edit: It’s not working for me.

What version does pamac provide? Wait, as Fred already said it’s likely libpamac,

Is that something they have to change?

Yes, the PKGBUILD will specify a version number. If the PKGBUILD is looking for pamac=11.1 then something has to provide that package with that version number (though I haven’t looked to see which packages provide=(pamac) )

Okay well i didn’t understand if it was fixed or just saying it needs this. I will wait.

I was able to update pamac-aur-git on two machines and i reinstalled it on the other. Seems to working again.

2 Likes

If you need to contact me? PM here. I won’t post here my mail :smiley:

1 Like

I forgot to say you need to upgrade both libpamac and pamac-aur-git… My bad!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.