Cannot browse Windows network from KDE Dolphin

Update to explain in greater detail:
After a fresh install of EOS Cassini, I’m attempting to browse the Windows network to get some files from a PC. I’m expecting Dolphin to browse the network and produce a list of Windows hosts that I can select from. However, when attempting to browse Dolphin fails to produce the host list. Here is where it gets strange:

I can connect to and interact with individual Windows host PCs if I explicitly connect to them via hostname or IP address. This requires me to know the hostname or IP address in advance, as well as know that the host is powered on. However, when attempting to browse the network I encounter a “No shared folders found” response from Dolphin instead of a list of Windows hosts. All of the hosts are configured to use DHCP and I’ve verified that the underlying network config and components are in place and working. All of the hosts respond to ping. I tried putting dummy info in the network settings within system settings, but it didn’t fix the issue.

I installed Manjaro v22.0.0 KDE on my kid’s PC and it is able to browse the Windows network and connect to Windows hosts normally. There is only a slight difference in Plasma versions between the Manjaro host and the EOS host. Manjaro is on Plasma 5.26.4 and Endeavouros is 5.26.5.

Below is data from “inxi -Fza” from the EOS host:

  Kernel: 6.1.5-arch2-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: initrd=\8aee483f01b1492aa27798ffd98c2966\6.1.5-arch2-1\initrd
    nvme_load=YES rw root=UUID=6a8a8596-2752-41f1-b40c-8e06a0572e30
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7
    dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG CROSSHAIR VIII HERO (WI-FI) v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4201
    date: 04/26/2022
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 gen: 4
    level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
    family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2579 high: 3800 min/max: 2200/4850 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3800 2: 3800
    3: 2200 4: 2200 5: 2200 6: 2800 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200
    12: 2200 13: 2874 14: 2200 15: 2200 16: 3800 bogomips: 121427
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-3
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0d:00.0 chip-ID: 1002:73bf
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: DP-3 mapped: DisplayPort-2 model: Dell S2721DGF
    serial: <filter> built: 2021 res: 1920x1080 hz: 120 dpi: 82 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon RX 6800 XT (navi21
    LLVM 14.0.6 DRM 3.49 6.1.5-arch2-1) direct render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound API: ALSA v: k6.1.5-arch2-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel modules: wl pcie:
    gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:2723
    class-ID: 0280
  IF: wlan0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-6:3
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 17.33 TiB used: 19.64 GiB (0.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SKC3000D2048G
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EIFK31.6 temp: 36.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Western Digital
    model: WD BLACK SN750 SE 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 711000WD temp: 44.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST10000DM0004-1ZC101
    size: 9.1 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: SBBA scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM006-2DM164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
  ID-5: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST4000NE001-2MA101
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: EN01 scheme: GPT
  ID-1: / raw-size: 476.92 GiB size: 468.37 GiB (98.21%) used: 7.29 GiB (1.6%)
    fs: ext4 dev: /dev/nvme1n1p2 maj-min: 259:5
  ID-2: /home raw-size: 488.28 GiB size: 479.55 GiB (98.21%)
    used: 12.25 GiB (2.6%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34
  Alert: No swap data was found.
  System Temperatures: cpu: 37.0 C mobo: 37.0 C gpu: amdgpu temp: 39.0 C
    mem: 40.0 C
  Fan Speeds (RPM): cpu: 0 gpu: amdgpu fan: 0
  Processes: 340 Uptime: 4h 1m wakeups: 0 Memory: 31.26 GiB
  used: 3.41 GiB (10.9%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1043 libs: 248 tools: yay Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.24

Is the samba completely installed and configured?
I didn’t think it was preinstall on Endeavour.

Samba is pre-installed on both EOS and Manjaro. No changes were made to it by me on either installation.

Who said samba is preinstalled on EOS? Not to my knowledge.

It doesn’t look like.
Follow these install/configurations

the samba package was already in place with an install date of 1-14-2023

I don’t recall Samba ever being an installed package on Eos as far as i know. Been here since the beginning. :thinking:

I apologize friends. I thought the smbclient tool was part of the samba package. Is the samba package required for Dolphin to be able to browse a network and discover Windows hosts?

server-computer (SAMBA / smb) <-------> client-computer (smbclient for linux)

The server computer serves up files upon request.
The client computer receives the files.

server-computer linux <-----> client-computer windows
this is the way I use Samba for the windows computer to access files on my linux ARM server.

It can go the other way also
server-computer windows <-------------> client-computer linux
I have never set up a windows smb server for a linux client.


1 Like

Thanks. At some later point I will setup a Samba server so that Windows clients can connect to my EOS PC. However, right now I’m trying to go from EOS/Dolphin (client) to Windows 10 (server). More specifically I am attempting to browse the network (in Dolphin) which should produce a list of Windows hosts that I can connect to.


Try disabling firewall first, and then try to refresh the network in dolphin again

sudo systemctl stop firewalld.service

IIRC, the (EOS’?) firewalld configuration will disable this network traffic by default.
If this works, someone else can help you with setting up firewalld correctly.

Good luck. :wink:
It was so simple with windows 98 or xp and even 7. But, after that windows make it so difficult on the Windows side. Once you get that working the Linux config should be easy.

Thanks. I tried disabling the firewall as you described but it did not work. I’ve been googling and reading. It seems there is a complicated history with the Network browse feature, Samba, SMBv1, Microsoft, etc. Many distros that offer KDE do not have the browse feature working. It seems Manjaro has found a way around the issues. I’ve asked in their forums as well but no one has offered info. on how they make it work.

I know that I can use ‘smb://the_hostname/’ or ‘smb://the_IP_address/’. I have DHCP setup through my router. So, when I entertain friends/loved ones who bring their Windows laptops and want to exchange files I have to get the full details of their:

  • hostname(s) (or IP addresses)
  • the exact spelling of the share(s) on their machines

It is much simpler and faster to browse → select host → authenticate → select share → exchange files. This really gets to be cumbersome when I host LAN parties and there are 30+ people at my home; and they are relatively tech savvy (yes I’m old school). When there are large numbers of folks a Samba server solution would be the better option but when there are only a few people coming at different times a Samba server solution may be over kill; especially if there are only a handful of files to exchange.

I appreciate you guys taking the time to assist. I am trying to persuade friends and love ones to make the leap to Linux, but in order to inspire confidence in them and convince them I need to be well verse in the details of the journey. I fully expect to lead training sessions with them so I’m going through the growing pains first.


It works on my EOS machine™ :smiley: Two machines in the list are running windows and one has linux samba server. I am not using firewalld but have a rule in ufw that allows samba traffic. YMMV, good luck.

Wow nice. How did you get it to work? I’m testing based on a fresh install of the OS without tweaks.

Nothing special really, just adjusted the firewall. Check this out

If you are going to set up your Linux computer as the server and windows computer(s) as client. In the Linux computer

  1. Samba must be installed and enabled - systemctl enable samba
  2. /etc/samba/smb.conf must exist and be configured. I don’t think EnOS supplies a smb.conf file. You can get one here
    $ wget
  3. you need to set up a samba user and password.
  4. you can go here for instructions to set up your windows computers.
  5. this all works best if the Linux computer has a static address.

It’s time for breakfast, will be back later if you have any questions.

Actually, it is easier and best to set up a headless server that will serve Linux computer via sshfs, Windows computers, and have miniDLNA media server.


1 Like

Thank you Pudge. I will be looking to setting up Samba server at later time. Right now I was trying to get EOS/Dolphin to act as a client to browse, discover, and connect to a Windows 10 PC. If a full configuration of Samba is required for Dolphin to be able to do the above please let me know.

Wouldn’t disabling the firewall remove it from the equation and thus allow the traffic through? If so, I disabled the firewall and browsing not work.

I’m afraid, you might have to go through some (if not all) of this:

As your Windoze is providing the samba server, just check the relevant parts.

On top, you might look into Discovering network shares:

Yes, that is why I gave you a suggestion to try and disable your firewall first.

There is another quick way to check if lookup is working correctly by using nmblookup
So for my zexzen machine it looks like this

$ nmblookup zexzen zexzen

This utility is part of samba client, you already have it installed, so you can try it too.

1 Like