Cannot bring up a TTY console in SDDM

I tried to bring up a TTY console in SDDM and it totally ignores any Ctrl - Alt + Fwhatever.
Ideas or comments?


My ThinkPad T430 has not been updated in a while. At sddm, I tried Ctrl-Alt-F3 and it brought up a TTY console. Next the updates (88 of them) were installed. I thought for sure sddm would be broken after updates.

After the updates, Crtl-Alt-F3 still brought up a TTY console. So it only happening on my Daily Driver so far.

Next I will try on the RPi 4b with KDE and see what happens there.


is this intel GPU one or optimus :wink:

Intel GPU. I checked before I bought it.


The Thinkpad T430 does work with Crtl-Alt-F whatever, it is my daily driver (AMD Ryzen) that is not working. The Ryzen device simply ignores the Crtl-Alt-FN keys. And Plasma on a RPi 4b also recognizes this key pattern.

I believe this is the first time I have tried launching a TTY console from SDDM since installing KDE Plasma about 5 or 6 weeks ago. I’m wondering if something did not get installed that is affecting this?

I use SDDM on several installations, and in all of them Crtl-Alt-FX (X=2…6) brings a TTY.

But I know that some machines mess with the keyboard such that you need Ctrl with the Fn keys when other machines don’t. If that’s the case, then some BIOS/Firmware setting for the keyboard might help.

This is my Ryzen Desktop device which has a standard 104 ? key keyboard. No Fn key.

This is the first time I have installed KDE Plasma on this particular desktop. So I have never tried this key combination before now.


I have to step out and run some errands. Back in approx 1 hour.

Works for me on Arch Plasma. I do notice one quirky thing though. If I hit CTRL+ALT+Fx it works first time so say CTRL+ALT+F2 back to CTRL+ALT+F1. If I continue holding CTRL+ALT and then hit Fx it does nothing the second try also a Ryzen machine. I have to release CTRL+ALT and reapply and then it works. It is almost like keystroke lag while in SDDM if that makes sense.

I have tried an AMD A10-7800K with XFCE4 and LightEM, an AMD Ryzen 7 2700 with KDE and sddm, RPi4 KDE and sddm, ThinkPad with KDE and every one works as expected, both with Ctrl-Alt-FX at the Desktop manager and from inside the Desktop environment.
For all of these, Ctrl-Alt-F1 brings you back to the DM GUI, or the DE GUI.

With the single problem desktop computer, It ignores all Ctrl-Alt-F combinations in sddm. In KDE with Konsole it ignores Ctrl-Alt-F 1 thru F6. With Ctrl-Alt-F7, it tries to go to a tty window in Konsole, but isn’t quite right. To bring Konsole back, one must use Ctrl-Alt-F7 again.

Is the KDE desktop running on TTY 7 on the problem computer, and all the rest running on TTY 1?


[don@Valhalla ~]$ tty
[don@Valhalla ~]$ who
don      tty1         2021-10-28 16:52 (:0)
[don@Valhalla ~]$

shows tty1 so it is not running on tty7.

Is there a way to determine which TTY a DE runs on?


I cannot believe it. I went back to @manuel 's post about keyboards. Why not?
I replaced the USB keyboard with another keyboard exactly like it except PS2.

It worked. Tried yet another USB keyboard exactly like it off my RPi 4b setup, and it worked.

I then put the suspect keyboard back in, DID NOT work. This simple device that has performed perfectly for so long, along with the strange symptom, was the last thing I suspected.

Right now I am running on the PS2 keyboard until I decide what to do.

My favorite keyboards are old KeyTronic keyboards that I have had for YEARS. I have four USB KeyTronics that have been in use, and one PS2 KeyTronic keyboard that has been sitting in a closet for many years.

The broken keyboard has been on my Daily Drivers for YEARS. It has the most use and abuse of all my KeyTronics keyboards

One of my favorite keyboards has died. I forget, how many stages of grief are there?



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.