Cannot boot up after installation

did as per instructions and installed refind.
still not booting up. here is what the screen shows

[    0.518806] pci 0000:00:07.0: DPC: RP PI0 log size 0 is invalid
[    0.519511] pci 0000:00:07.2: DPC: RP PI0 log size 0 is invalid
:: running early hook [udev]
Starting version 247.3-1-arch
:: running hook [udev]
:: Triggering uevents...
:: running hook [keymap]
:: loading keymap...done
ERROR: device '' not found. Skipping fsck.
:: mounting '' on real root
mount: /new_root: no filesystem type specified.
you are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs  ]#_

The problem is I can’t see or know exactly what you are doing? With rEFInd only one of the icons works. The other one you have to hide it after.

1 booted into the ext 4 option and got the above.
when i booted in the fat 32/efi option i got the same error as before as that took me to the grub screen.

here is what gparted shows

there is no ‘/’ on the main partition. should i reinstall using the manual option and setting the required mount point/flags ?

nals

Edit by @manuel: made the picture visible.

Okay I’m not sure what you mean by this. But if you want to do another install you could try. If you do manual partitioning you need to understand what is required and how to do it. I really don’t know why this isn’t working as the last install looks correct.

Not sure if mentioned before but that fstab you posted at the bottom after /boot/efi it lists vfat, that is incorrect fs for esp boot partition and should be fat32 for best formatting, vfat if for partitions that are over 32gb I believe that is extented fat32 parttion is what vfat is. If that is the automatic formatting from endeavour then instead create your own partitions /boot/efi 512mb fat 32 with boot esp flags for this boot partition, then creat your root fs with from your previous posting 500gb ext4 mounted at /, then home partition “the rest of the gb’s” ext4fs mounted at /home. I wouldn’t mess with block sizes or anything just do the most basic stuff. Also the non booting partion, I’ve found you have to install any ubuntu mint based disto’s first or at least before arch, if you do it after the arch will not boot but installing arch based after then both distro’s will boot. For some reason ubuntu mint do not like to boot arch so arch install last has been a rule of mine for a few years now.

You can reinstall normally, but be sure to select the mount points correctly.

By the way, now the disk usage is much better. It is closer to solution now.

This is how mount points should look like in gparted (this is in a virtual machine):

boot in UEFI[Legacy] is not good
recheck all option in your UEFI

SecureBoot off
Fast Boot off
No CSM
No Legacy
all disks on AHCI

you can check in terminal

inxi -Fxza
test -d /sys/firmware/efi && echo efi || echo bios

sudo parted -l

your disk is GPT , boot on UEFI[Legacy] will try to install in MBR…

1 Like

@nals

I hope you can do as @Stephane has suggested especially to verify some of the things that have been suggested in most of the posts so it can be determined that things are the way they need to be. We are trying to help get this resolved. If there is anything you don’t quite understand please ask. There are no stupid questions here.

1 Like

thanks for all the inputs
confirm secure boot and fast boot are off, and disk is on AHCI. could not find legacy or CSM buttons, perhaps as is new computer.

this is what the set up shows when i set up the manual partitioning, sets up mount point for /boot/efi on the fat 32, sets up mount point /home on ext 4. does not set up a mount point for ‘/’, root. you can view it on the image

perhaps needs some editing to see the image.

I don’t know how you are trying to upload these images but it is making this very difficult. You only need to save the image and then use the upload arrow up in the window here to upload your image. I am having difficult understanding why you say there is no /
I have used virtual box and created a 40GB un-allocated space and then used gparted to create the partitions. Then i show the installer started and i edit the partitions using manual partitioning in order to set and flag them as /boot/efi, /, /home & swap file.

This next image shows them all edited using the installer and manual partitioning.

The next screen is where you select the desktop from the online install.
As you can see i have used manual partition in the installer to edit each partition that i created with gparted. First is a 300MB /efi partition flagged /boot/efi and marked /boot. Next i edited the 12 GB partition and flagged it as /. Then i edited the 20 GB partition and flagged it as /home. Then i edit the last partition and flagged as linux-swap.

When you say there is no root it should be in the drop down box as /

/=root

Edit: The first image shows a 40 GB partition i created first in order to show you how to create the partitions first with gparted before starting the installer. Yes there are other ways to do it but i just don’t know how to explain it to you any other way. Then once you start the installer you use manual partitioning and edit each of the partitions in order to set and flag them properly. You can do all of this in the manual partitioning screen also without creating them first with gparted as it uses this tool to do it. I only do it this way to try to explain it.

Edit2: If you were using manual partitioning only you would use create instead of edit to create, set and flag each partition from your disk.

1 Like

Simply don’t use backticks (```) around images. Backticks are for showing source code etc.

I see create 600 MIB partition as ext4 & flag 600 MIB as root? This is way too small. It’s no wonder it won’t install properly! This needs to be like 20 GB? I don’t know what the minimum is but the drive is plenty large enough so i would use 20GB.

Edit: Here’s what you need.

300 MB minimum /efi
20 GB /
the rest of the drive size can be /home
You can create a swap partition or make a swap file after the installation. There are many ways of doing things.

1 Like

@manuel
Am i right here? 600 MB is too small for / What is the minimum? I said 20GB because it’s a 1TB drive.

Edit: According to the Arch wiki

/ traditionally contains the /usr directory, which can grow significantly depending upon how much software is installed. 15–20 GiB should be sufficient for most users with modern hard disks. If you plan to store a swap file here, you might need a larger partition size.

You’re right. 600MB for / is way too small.

In this case I see no reason to have a separate /home either.
Simply the default settings (automatic partitioning) should be OK. And is less error prone.

I can only say that there should be absolutely no reason for it not installing using automatic partitioning. I can’t see one.

firstly, sorry for uploading screenshot images incorrectly.

rick, thanks for your detailed instructions, i confirm i am following the same procedure.

making a new attempt, here is how i partitioned the disks


shows the root as having mount point /

thereafter as i move on with the installation and it asks me to confirm the disk partition it drops setting up a mount point /. there is no mention of ‘with mount point/’ as there is for the efi partition. see below

hence if i install as is, the partition does not mount, and the boot loader cannot find the device.

at least that is what i think is happening.

Would you please try automatic partitioning?

yes, will do so and revert tomorrow

The only thing that i can think of after seeing all this and going through all these posts is that you have Time zone set to Asia/Tokyo. System language is set to American English. The numbers and dates locale is set to Japanese?

I am wondering if the automatic install doesn’t work you could please try an automatic install but set everything to American English. I am just wondering if the Numbers and Dates locale setting is possibly creating an issue with some symbols? and it is getting confused. We have never had this problem of an install not working like this. Thanks for sticking with it.

i tried automatic install and setting everything to english, time zone usa, new york
still the same issue, does not set up a mount point ‘’/’’

perhaps the installer provides some clues.

19:45:22 [0]: QObject::setParent: Cannot set parent, new parent is in a different thread
19:45:22 [6]: QVariantList FillGlobalStorageJob::createPartitionList() const
    Building partition information map 
    ..  partitions on "/dev/nvme0n1" 
    ..  mapping for "" "unallocated" 
     partlabel :   "" 
     partuuid :   "" 
     parttype :   "" 
     partattrs :   "0" 
     mountPoint: :   "" 
     fs: :   "unknown" 
     fsName :   "unknown" 
     uuid :   "" 
     claimed :   "false" 
    ..  mapping for "" "New Partition" 
     partlabel :   "" 
     partuuid :   "" 
     parttype :   "" 
     partattrs :   "0" 
     mountPoint: :   "/boot/efi" 
     fs: :   "fat32" 
     fsName :   "fat32" 
     uuid :   "" 
     claimed :   "true" 
    ..  mapping for "" "New Partition" 
     partlabel :   "" 
     partuuid :   "" 
     parttype :   "" 
     partattrs :   "0" 
     mountPoint: :   "/" 
     fs: :   "ext4" 
     fsName :   "ext4" 
     uuid :   "" 
     claimed :   "true" 
19:45:22 [6]: QVariantList FillGlobalStorageJob::createPartitionList() const
    Building partition information map 
    ..  partitions on "/dev/nvme0n1" 
    ..  mapping for "" "unallocated" 
     partlabel :   "" 
     partuuid :   "" 
     parttype :   "" 
     partattrs :   "0" 
     mountPoint: :   "" 
     fs: :   "unknown" 
     fsName :   "unknown" 
     uuid :   "" 
     claimed :   "false" 
    ..  mapping for "" "New Partition" 
     partlabel :   "" 
     partuuid :   "" 
     parttype :   "" 
     partattrs :   "0" 
     mountPoint: :   "/boot/efi" 
     fs: :   "fat32" 
     fsName :   "fat32" 
     uuid :   "" 
     claimed :   "true" 
    ..  mapping for "" "New Partition" 
     partlabel :   "" 
     partuuid :   "" 
     parttype :   "" 
     partattrs :   "0" 
     mountPoint: :   "/" 
     fs: :   "ext4" 
     fsName :   "ext4" 
     uuid :   "" 
     claimed :   "true" 
19:45:29 [8]: QML Component (default slideshow) Next slide

is there a way to install a very basic version from the terminal, creating the right mount point, and building from there ?

sincerely thank you all for spending the time on this