Cannot boot into the zen kernel

I have been using the zen kernel for ages. It is necessary to keep my laptop usable as with the vanilla kernel, the idle temps and fan noise get too high.

Since yesterday, I have only been able to boot into the vanilla kernel. If I select the zen kernel, it just shows a blank screen forever instead of asking for my encryption password. I have tried re-installing (and even downgrading one version) the linux-zen and linux-zen-headers packages, but I have no idea as to how to proceed further without error messages.

I use an NVIDIA hybrid laptop.

What do I do here? Anyone has any ideas?

Edit: I have tried installing the LTS kernel. It works. It is just the zen kernel that seems not to work

I cannot switch to a tty from booting into the zen kernel. It is supposed to ask me for my full disk encryption password after I select the kernel. That never happens unless I use the vanilla kernel

What does pacman -Q | grep nvidia show?

nvidia-dkms 535.86.05-2
nvidia-hook 1.3-1
nvidia-inst 23-6
nvidia-installer-common 23-6
nvidia-settings 535.86.05-1
nvidia-utils 535.86.05-2

Are you using dracut or mkinitcpio?

mkinitcpio, my installation is from before endeavour switched to dracut. But I use systemd-boot as I manually installed it replacing grub

Try rebuilding your boot images with sudo mkinitcpio -P

I have, many times already. It finishes without errors. It also runs whenever I reinstalled zen kernel as well

Does it work if you boot into the fallback initramfs?

No, it still does not boot

I would try downgrading the zen kernel and headers. Perhaps it is an issue with the latest kernel itself.

did that already. I downgraded it one version number down with eos-downgrade. Did not seem to fix it

I am right now on 6.4.6. Zen does not boot, vanilla and lts kernels do. I knocked zen down to 6.4.5 but it still doesn’t boot

Edit: typo

It worked! I’d only knocked the kernel version down by a single version the last time. I tried to knock it down by several versions while experimenting, and it now boots perfectly!

Right now I am on 6.4.3. What do I do from here? Do I wait for a zen version that will work? Linux zen is pretty mission critical to me, I couldn’t use the computer without it. I’d have to switch to something Debian based without the arch version working for me and I don’t want to.

I’m thinking this error is specific to my machine. Can I trust that a newer version would solve whatever was causing zen not to boot in my machine? I’m skeptical because the last two versions did not work

You should notify the ZEN kernel team about your issue and let them investigate. The issue could be related to one of their patches.

1 Like

6.4.7 zen and no issues at all. Actually I didn’t had any issues with previous kernels either. Updating as normal and didn’t notice nothing except boot is a little slower.
Dualbooting Debian/EOS and Debian is running 6.4.7. No issues there either. Booting fine with Debian grub.