Cannot boot after latest update (stuck at initializing ramdisk)

Hello all,

Last night, I updated system then went to bed. Today, I am unable to boot. After GRUB, it stops at “initializing ramdisk”. The fallback doesn’t work, either.

I’m currently running the live enviroment. I’ve tried mounting the boot drive and running pacstrap /mnt base linux linux_firmware, but it returns with “error: target not found: linux_firmware”

I’m wondering if I’m not mounting boot/root at all. Can someone please help me? I’d rather not have to reinstall EndeavourOS if it can be avoided.

I am not sure using pacstrap is the right thing to do here.

Can we see inxi -Fxxxz from the live environment?

Also, when you boot your system normally, after it sits there for a minute, can you switch to a TTY?

Try pressing alt+ctrl+F3

Hi Dalto, here is the output of inxi -Fxxxz

Edit: alt + ctrl + F3 does nothing.

System:    Kernel: 5.11.14-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.16.0 
           tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 1 dm: LightDM 1.30.0 
           Distro: EndeavourOS base: Arch Linux
Machine:   Type: Laptop System: Hewlett-Packard product: N/A v: N/A serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 1853 v: 71.13 serial: <filter> UEFI-[Legacy]: Insyde 
           v: F.05 date: 04/23/2012 

Battery:   ID-1: BAT0 charge: 69.4 Wh (100.0%) condition: 69.4/69.4 Wh (100.0%) volts: 12.2 
           min: 11.1 model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech M570 serial: <filter> charge: 95% 
           rechargeable: yes status: Discharging 

CPU:       Info: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge 
           rev: 9 cache: L2: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 19962 
           Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197 2: 1357 3: 1197 
           4: 1209 

Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard driver: i915 
           v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300 
           Device-2: AMD Heathrow PRO [Radeon HD 7850M/8850M] vendor: Hewlett-Packard 
           driver: radeon v: kernel bus-ID: 01:00.0 chip-ID: 1002:6827 class-ID: 0300 
           Device-3: Importek HP TrueVision HD type: USB driver: uvcvideo bus-ID: 2-1.6:4 
           chip-ID: 10f1:1a37 class-ID: 0e02 
           Display: server: 1.20.11 compositor: xcompmgr driver: loaded: ati,intel,radeon 
           unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 

Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403 
           Device-2: Microchip (formerly SMSC) HP Wireless Audio Adapter type: USB 
           driver: hid-generic,snd-usb-audio,usbhid bus-ID: 2-1.5:3 chip-ID: 0424:b832 
           class-ID: 0300 
           Sound Server-1: ALSA v: k5.11.14-arch1-1 running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.25 running: no 

Network:   Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel port: 4000 
           bus-ID: 07:00.0 chip-ID: 8086:088e class-ID: 0280 
           IF: wlan0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Hewlett-Packard 
           driver: atl1c v: kernel port: 2000 bus-ID: 0e:00.0 chip-ID: 1969:1083 class-ID: 0200 
           IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 

Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb 
           v: 0.8 bus-ID: 1-1.1:3 chip-ID: 0a12:0001 class-ID: e001 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 

Drives:    Local Storage: total: 713.18 GiB used: 332.63 GiB (46.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST750LX003-1AC154 size: 698.64 GiB 
           speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: HPM1 scheme: MBR 
           ID-2: /dev/sdb type: USB vendor: Toshiba model: TransMemory size: 14.54 GiB 
           serial: <filter> rev: PMAP scheme: MBR 

Partition: ID-1: / size: 10 GiB used: 189.5 MiB (1.9%) fs: overlay source: ERR-102 

Swap:      Alert: No Swap data was found. 

Sensors:   System Temperatures: cpu: 39.0 C mobo: 39.0 C gpu: radeon temp: 43.0 C 
           Fan Speeds (RPM): N/A 

Info:      Processes: 202 Uptime: 38m wakeups: 4 Memory: 7.67 GiB used: 2.18 GiB (28.5%) 
           Init: systemd v: 248 target: Compilers: gcc: 10.2.0 Packages: 
           pacman: 896 Shell: Bash v: 5.1.4 running-in: xfce4-terminal inxi: 3.3.03

I had the same problem.

[Edited to remove the inxi output]

I’ve just tried rebooting and now get a [FAILED] Failed to start Light Display Manager error which would make sense since I was adjusting some libinput configurations and had broken something. Fixing that via the live environment got things working again.

Edited your inxi output for readability by surrounding it with 3 backticks (```).

Note that our wiki provides many useful tips, for example this about chrooting:

This way you can kind of “boot” into your installed system and give terminal commands.
You just need the USB installer with which you can boot the machine.