Cannot adjust gamma on KDE Plasma 5

Hello! Just switched from dualboot Windows 10/Manjaro LInux to Endevour OS. Facing a problem with adjusting gamma settings for my display. The issue seems to have appeared after I finished tinkering with Nvidia drivers, as it was not an issue before.

Additionally, when I try to save gamma preferences system-wide, i face this error:

Cannot execute command ’ xf86gammacfg x.xx x.xx x.xx’‘’

Here’s the information about my system:

System:
  Kernel: 6.6.8-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.27.10
    Distro: EndeavourOS
Machine:
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec0xxx v: N/A
    serial: <superuser required>
  Mobo: HP model: 86D5 v: 96.45 serial: <superuser required> UEFI: AMI
    v: F.17 date: 03/16/2023
Battery:
  ID-1: BAT0 charge: 40.7 Wh (100.0%) condition: 40.7/40.7 Wh (100.0%)
CPU:
  Info: quad core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx
    bits: 64 type: MT MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1473 min/max: 1400/2100 cores: 1: 1400 2: 1315 3: 2100
    4: 1400 5: 1370 6: 1400 7: 1400 8: 1400
Graphics:
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
    v: 545.29.06
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-3: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.10 driver: X:
    loaded: modesetting,nvidia dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
  API: Vulkan v: 1.3.274 drivers: nvidia surfaces: xcb,xlib
Audio:
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.6.8-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8822ce
  IF: wlan0 state: up mac: 70:66:55:05:ae:ab
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: eno1 state: down mac: 38:22:e2:24:52:ce
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb type: USB
  Report: btmgmt ID: hci0 state: up address: 70:66:55:05:AE:AA bt-v: 5.1
Drives:
  Local Storage: total: 476.94 GiB used: 147.04 GiB (30.8%)
  ID-1: /dev/nvme0n1 vendor: KIOXIA model: N/A size: 476.94 GiB
Partition:
  ID-1: / size: 452.76 GiB used: 146.81 GiB (32.4%) fs: ext4 dev: /dev/dm-1
Swap:
  ID-1: swap-1 type: partition size: 14.86 GiB used: 0 KiB (0.0%)
    dev: /dev/dm-0
Sensors:
  System Temperatures: cpu: 68.0 C mobo: N/A
  Fan Speeds (rpm): fan-1: 0 fan-2: 0
  GPU: device: nvidia screen: :0.0 temp: 47 C device: amdgpu temp: 68.0 C
Info:
  Processes: 303 Uptime: 24m Memory: total: 16 GiB note: est.
  available: 13.52 GiB used: 3.27 GiB (24.2%) Shell: Bash inxi: 3.3.31

I’ve searched for a solution on the internet for quite a long time now, and solutions like “nevermind, an update fixed it” drive me crazy. So I decided to ask you guys here on the forum. Thank you in advance.

Aight, some time has passed, and I realized that the issue was that while Optimus Manager is set on Nvidia mode - which is default in my case -, the gamma settings don’t get adjusted. However I found out that redshift can override these limitations somehow, so at first I used to change the gamma settings with redshift -g command manually, and eventually came up with a bash script with my preferences.