Cannot Add new VPN Connection


I am having a problem when trying to add a VPN connection.

Heres what I am doing:

Click on network icon → VPN conections → Add VPN Connections → Select Import Save VPN Connection → Create → UI Crashes

I am on i3 and running on VMware Player:

I also found a similar issue that I tried suggested fix on:


From the reply to one of the threads, I do not have the path path="/org/gnome/nm-applet/eap/" in my /usr/share/glib-2.0/schemas/org.gnome.nm-applet.eap.gschema.xml. I still tried to compile using glib-compile-schemas setting /usr/share/glib-2.0/ as the directory.

i have

libnma 1.10.6-1
libnma-common 1.10.6-1

I also tried to launch the network manager from the terminal using nm-connection-editor and did the same steps, this is what i get in the terminal:

Segmentation fault (core dumped)

I check the logs using journalctl -x and got the following:

Another thing I tried was to edit my existing local network connection. As from the previous threads suggested that its an issue on the network manager. I was able to update and configure my local wired connection, like changing name, setting it to DHCP to static and back.

Im really new to arch and eos in general so please excuse my newbie-ness.

Thanks for any suggestions or help!


In my VM, I use the below to add my ovpn files to network manager.

sudo nmcli connection import type openvpn file /etc/openvpn/client/aws.ovpn
sudo nmcli connection import type openvpn file /etc/openvpn/client/client.ovpn

hi sammiev,

Thanks for the reply! I can try that. But I want to fixed the nm-connection-e crashing.


That will install it into networkmanager and you will be able to edit, turn it off and on. Any errors from the terminal post them here. I only have to use this method from within a VM to import a ovpn config.

aces! Thanks sammiev!.. not errors at all… now the question is… how do I fix the nm-applet crash? I have been rsearching and nothing comes up from what I can see. Do you ahve any suggestion where I can check aside from the journalctl to check for errors?


I believe it’s the way the VM gets the connection from the host. I never really looked into it or needed to.
You should be able to edit it now in networkmanager, start and stop it and whatever you want.
I also do the same for wireguard but change openvpn to wireguard. Glad I was able to help and Good Luck.

Hey sammiev, just an fyi, its not only happening in VM, I have an LG 15, running on EOS with i3. I just checked today, I cannot used the nm-editor to add new vpn. Which I remember I was able to before since I already have config added to it.

Thanks for the heads up, I never tried adding a new connection by importing on a bare metal install in a while, but always adding vpn or wireguard connections to VM.

Most welcome, do you have any suggestions how to fix it? In my original post, journalctl -x is showing an error, but not sure how to fix it.

I just tested to add a .ovpn with nm-connection-editor run from a terminal and got

Segmentation fault (core dumped)

It seems to be DE independent. This was on an Arch-GNOME system.


There is this bug report at:

Severity Low
Priority Normal

And upstream:

Quoting the bug reporter:

Downgrading to nm-connection-editor ver 1.30.0-1 allows me to import the file.

1 Like


I can confirm that downgrading nm-connection-editor (1.32.0-1 => 1.30.0-1) works as a temporary solution/workaround:

Terminal output:

Message: 07:12:35.736: Connection validates and can be saved

1 Like

omg! Thanks pebcak! will try to downgrade!


EDIT: Thank you @pebcak its working now. Will wait for the official fix then upgrade to latest XD

1 Like

You are welcome! Glad to hear that it is working now!

In the meantime, if you don’t want to add nm-connection-editor to your pacman.conf to be ignored, you could pass --ignore nm-connection-editor to pacman when updating the system:

sudo pacman Syu --ignore nm-connection-editor

Personally, I prefer this to adding it to the conf file.

1 Like

There is a fix in the pipeline:

So we can be expecting an update to this package within shortly.


The issue is now fixed in 1.32.0-2

1 Like

amazing! thanks @pebcak for keeping an eye on this and letting me know! you are awesome!

1 Like

You are welcome! Happy to help! :enos: :wave:t5: