Can’t install 2070 Max-Q drivers on Endeavour, returns Error 43 in Windows

I was running EndeavourOS on my Gigabyte AERO15-X9. I updated using yay, Konsole hung, and then my laptop shut off. I could no longer boot into Endeavour, so I reinstalled it. No matter how hard I tried, I couldn’t get my GPU drivers to install properly. I then installed Windows 10, and after GPU driver installation I was met with an error 43 code, meaning there was a driver error. After this, I partitioned my drive and reinstalled Endeavour.
Using nvidia-smi yields No devices were found or NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver
These are the methods I’ve tried on Endeavour

  1. Installing latestnvidia-dkmsdrivers
  2. Installing latestnvidiadrivers
  3. Installing open nvidia drivers```
sudo ./NVIDIA-Linux-x86_64-525.116.04.run -m=kernel-open
sudo update-initramfs -u
sudo reboot

Methods not tried

  1. Switch to X11 instead of Wayland
    I’ve generated an nvidia-bug-report.log file, which I’ll include here. I’m really at a loss of where to go from here, beyond trying every driver version I possibly can. Any help is appreciated, I’m probably missing some crucial step/process!

When you installed EOS did you use the nvidia option to install it? This is what installs the nvidia drivers.

Edit:

This has nothing to do with EOS. It’s a totally separate issue on Windows.