Can’t figure out how to install nvidia drivers (Linux-Zen)

Hey guys, new here !!
Can’t figure out how to install nvidia drivers (Linux-Zen)
(In normal Linux kernel it is fine.)
so i will list many thing i tried to do.

here is the output of inxi -Faz

[salihberatyercel@salih ~]$ inxi -Faz
  Kernel: 6.0.10-zen2-1-zen arch: x86_64 bits: 64
    compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
    root=UUID=0e3a220a-2231-4b61-b8aa-65cd975344bd rw
    loglevel=3 nowatchdog nvme_load=YES
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.35
    wm: gnome-shell dm: GDM v: 43.0 Distro: EndeavourOS
    base: Arch Linux
  Type: Laptop System: Dell product: G3 3590 v: N/A
    serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Dell model: 061RYD v: A00
    serial: <superuser required> UEFI: Dell v: 1.17.0
    date: 03/24/2022
  ID-1: BAT0 charge: 31.6 Wh (100.0%)
    condition: 31.6/51.0 Wh (61.9%) volts: 12.4 min: 11.4
    model: BYD DELL M4GWP9B type: Li-poly
    serial: <filter> status: full
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP
    arch: Coffee Lake gen: core 9 level: v3 note: check
    built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10)
    microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12
    smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB
    desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3634 high: 4401 min/max: 800/4500
    scaling: driver: intel_pstate governor: powersave
    cores: 1: 4363 2: 2600 3: 4371 4: 4391 5: 4400
    6: 2600 7: 4292 8: 2600 9: 2600 10: 4401 11: 4399
    12: 2600 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1
    sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX:
    conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers;
    SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative
    Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs
    barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
    vendor: Dell driver: i915 v: kernel arch: Gen-9.5
    process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]
    vendor: Dell driver: N/A alternate: nouveau
    non-free: 520.xx+ status: current (as of 2022-10)
    arch: Turing code: TUxxx process: TSMC 12nm
    built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:2191 class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD type: USB
    driver: uvcvideo bus-ID: 1-5:4 chip-ID: 0c45:671f
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland
    v: 22.1.5 compositor: gnome-shell driver: X:
    loaded: modesetting dri: iris gpu: i915
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
    s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0819
    built: 2018 res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel
    UHD Graphics 630 (CFL GT2) direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 1-3:3 bus-ID: 00:1f.3 chip-ID: 0d8c:0012
    class-ID: 0300 chip-ID: 8086:a348 class-ID: 0401
  Device-2: NVIDIA TU116 High Definition Audio
    vendor: Dell driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
  Device-3: C-Media USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.10-zen2-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi
    driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a370 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express
    Gigabit Ethernet vendor: Dell driver: r8169 v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak
    (JfP) type: USB driver: btusb v: 0.8 bus-ID: 1-14:6
    chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down
    bt-service: disabled rfk-block: hardware: no
    software: no address: see --recommends
  Local Storage: total: 1.49 TiB used: 139.04 GiB (9.1%)
  SMART Message: Unable to run smartctl. Root
    privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: BC511 NVMe 512GB size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 11004101
    temp: 46.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba
    model: MQ04ABF100 size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 02
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB
    vendor: SanDisk model: USB 3.2Gen1 size: 114.61 GiB
    block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash
    drive/Unsupported enclosure?
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 33.05 GiB (7.1%) fs: ext4 dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB
    size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 65.0 C pch: 64.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 275 Uptime: 7m wakeups: 1 Memory: 31.15 GiB
  used: 2.4 GiB (7.7%) Init: systemd v: 252
  default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 alt: 11 Packages: pm: pacman pkgs: 1191
  libs: 324 tools: yay pm: rpm pkgs: 0 Shell: Bash
  v: 5.1.16 running-in: cool-retro-term inxi: 3.3.23

here is the output of pacman -Qs nvidia
[salihberatyercel@salih ~]$ pacman -Qs nvidia

local/libvdpau 1.5-1
    Nvidia VDPAU library
local/nvidia-dkms 525.60.11-1
    NVIDIA drivers - module sources
local/nvidia-hook 1.0-1
    pacman hook for nvidia
local/nvidia-inst 1.7-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-installer-common 1.7-2
    Common scripts for nvidia-installer-dkms and nvidia-inst
local/nvidia-settings 525.60.11-2
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 525.60.11-1
    NVIDIA drivers utilities
local/opencl-nvidia 525.60.11-1
    OpenCL implemention for NVIDIA

here is the output of journalctl -b -p3 --no-pager --no-hostname

[salihberatyercel@salih ~]$ journalctl -b -p3 --no-pager --no-hostname
Ara 03 15:21:57 kernel: x86/cpu: SGX disabled by BIOS.
Ara 03 15:21:57 systemd-modules-load[287]: Failed to find module 'nvidia-uvm'                                                     
Ara 03 15:21:58 systemd[479]: kod.service: Failed at step EXEC spawning /usr/local/bin/ No such file or directory (Note from me: I was tried a bash script and thats it.)         
Ara 03 15:21:59 kernel: nvidia-gpu 0000:01:00.3: i2c timeout error e0000000                                                       
Ara 03 15:21:59 kernel: ucsi_ccg 0-0008: i2c_transfer failed -110
Ara 03 15:21:59 kernel: ucsi_ccg 0-0008: ucsi_ccg_init failed - -110                                                              
Ara 03 15:22:08 gdm-password][1096]: gkr-pam: unable to locate daemon control file                                                
Ara 03 15:22:09 systemd[1198]: Failed to start Application launched by gnome-session-binary.                                      
Ara 03 15:22:09 systemd[1198]: Failed to start Application launched by gnome-session-binary.                                      
Ara 03 15:22:09 systemd[1198]: Failed to start Application launched by gnome-session-binary.                                      
Ara 03 15:22:10 systemd[1198]: Failed to start Application launched by gnome-session-binary.                                      
Ara 03 15:22:12 gdm-launch-environment][564]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

as you can see apparently no drivers are available for my nvidia card
i checked with nvidia-smi and i get this
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
i tried to install the drivers with nvidia-inst

[salihberatyercel@salih ~]$ nvidia-inst
2022-12-03 15:36:32: Info: Running: nvidia-inst v1.7-1
2022-12-03 15:36:32: Info: Command line: nvidia-inst 
2022-12-03 15:36:32: Info: Selected mode: nvidia
NVIDIA card id: 2191
Fetching driver data from ...

I also using nano added the ibt=off kernel parameter to the existing default grub command line in /etc/default/grub. Then updated grub with sudo grub-mkconfig -o /boot/grub/grub.cfg

and it seems to work i mean i don’t get any errors but inxi -G shows me the same result but still i do get some errors and nvidia-smi still fails
any ideas on what might be the problem ?Thank you.

Could be the MODULES values in /etc/mkinitcpio.conf.
You could try making it empty:


and then run commands

mkinitcpio -P

But before you do that, it is advisable to make sure you have a working USB installer stick available. :wink:

Do you have the headers installed for the zen kernel?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.