Can´t delete folder: i/o error

Hi there,

I would appreciate any help.

I have a folder on a USB drive (Sandisk external SSD) which I can’t delete.

The folder is named as found.001. If I try to remove it with sudo rm -rf found.001 command, the error rm: impossible to remove 'found.001/IndexerVolumeGuid': i/o error happens.

I also tried to unmount the drive, in order to properly run fsck, but the following error happens, preventing the operation: umount: /run/media/my_user/External_SSD: target is busy.

Any idea about that, please?

Thanks in advance.

This usually means that you have a terminal open that is in that dir or a file manager.

So, this is very strange, because I have no terminal or file manager open at this moment.

Due to all these problems, maybe this drive is starting to fail?

Can you change directory into it and make a list of what’s inside it ?
$ ls -lia

Sure. Here you go:

ls -lia
ls: não foi possível acessar 'IndexerVolumeGuid': Erro de entrada/saída
total 4
4755 drwxrwxrwx 1 root root    0 out 26 14:23 .
   5 drwxrwxrwx 1 root root 4096 out 26 14:40 ..
   ? -????????? ? ?    ?       ?            ? IndexerVolumeGuid

The error above means “ls: impossible to access ‘IndexerVolumeGuid’: I/O error”

I’ll do a quick search. I’ll be back.

If you are inside this folder: go up one.

$ cd ..

This might not work if there’s a physical cable or controller problem but let’s try:

$ rmdir found.001

Well, no luck, unfortunately. The below error happens:

rmdir: falhou em remover 'found.001': Diretório não vazio

Translating it: failed when removing ‘found.001’: directory not empty"

While that just happened, do you see some red messages in your journal at the end about your controler:

$ journalctl -b 0

Just checked here, and no red messages. :frowning:

Ok, I’ll let the big guns give you better feed back, I don’t want to abuse your time.
Take care.

No problem. Thank you very much. :slight_smile:

It looks like something that may be easier to sort out from your Windows installation.

Hi @BluishHumility ,

Thank you so much. :slight_smile:

Your post did make me think a bit more, and I solved the issue just by opening Nautilus as root and from that deleting the folder normally.

Many thanks!

That is curious; I would not have expected that to work if sudo rm -rf did not work. But glad to hear you got it sorted out!

Yes, me too.

That was very strange.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.