Can not update 4/13/20

When attempting to login to the ProtonMail Bridge, I get an issue about not having a keychain. What is the recommended keychain package for a Plasma system?

image

Edit: Fixed the nss error I initially had in post via Update needs manual intervention Somehow I thought it would be in announcements or something.

Search is you friend :hugs:

https://www.archlinux.org/

1 Like

Yep, already edited OP, and the recommended similar posts didn’t show it despite saying nss multiple times. ¯\(ツ)/¯ Already edited post to remove that issue. Still trying to figure out the deal with PMB keychain

1 Like

I’m not understanding what was wrong with it? I see the \ :thinking:

I am not sure either maybe it was just a copy paste thing. I have now seen it twice where users had an issue updating because they issued this command:

pacman -Syu --overwrite /usr/lib*/p11-kit-trust.so

2 Likes

nss package issue is fixed, no need to further comment on it in this thread, just the Bridge, please

You should start a new thread for this second issue :hugs: Also maybe stop by the endeavouros wiki and start with the information users usually add to their post when asking for help…logs and such :grinning:

1 Like

What desktop are you using?
Edit: The linux version of the Bridge is in Beta. Are you a paid subscriber?

From the Site: Proton Mail
If you have it installed on Linux, make sure you have either Gnome keyring or Pass apps installed on your device. It is required to log in to Bridge. We are working on supporting more password managers in the future.
Edit…Okay i see you posted under Plasma. :grinning:

1 Like

It was : https://www.archlinux.org/

1 Like

Thanks for humoring my stupidity you two and failure to look up any dependencies on the website, I figured given I was using a bin, protonmail-bridge-bin, and the terminal references a keyring when building stuff perhaps something was slightly off. Installing gnome-keyring and rebooting fixed the issue.

2 Likes