Can not install several packages (such as, google-chrome) with yay, or paru

I’m new to Arch/EndeavourOS.

I have small problems after installation, but I managed to solve them. But, installing some packages, such as google-chrome using yay or paru without success.

I update with:

yay -Syu

With yay:

yay -S google-chrome

It shows error messages:

 -> error making: google-chrome-cannot find package name: []
 -> Failed to install the following packages. Manual intervention is required:
google-chrome - cannot find package name: []

And with paru:

paru -S google-chrome

The error messages:

google-chrome-123.0.6312.58-1: parsing pkg list...
error: can't find package name in packagelist:.
error: packages failed to build: google-chrome-123.0.6312.58-1

I can install it successfully with makepkg -si though.

Do you have an alias or a function for yay?

Welcome to the forum.

Try this please:

sudo pacman -Syy && sudo pacman -S archlinux-keyring endeavouros-keyring && yay -S google-chrome

Edited with dalto’s logical suggestion.

Please don’t ever use sudo with yay

1 Like

Lol. That was a mistake because originally I had pacman there instead of yay. Just forgot to remove the sudo.


Also, you probably shouldn’t run pacman -Syy without updating. Next time you install a package you will be in a partial update scenario.

Lastly, there is no reason to do pacman -Syy followed by pacman -Sy. That does literally nothing but waste bandwidth.


Thank you.
No success!
I have the same error message.

It’s a fresh installation of EndeavourOS.

Never had such a scenario as a result of this.

And yeah, this makes sense. This is actually a copy-pasted old command I saw on this forum over a year ago. Never really thought about the fact that it should just be “-S” with no “y”.

It isn’t theoretical. It will happen 100% of the time when a package has been updated.

If you update your system at a given point in time, “A”. Then at a later point in time, “B”, you run pacman -Sy. The next time you install a package, it will come from the database from timeline “B”. That new package you installed comes from timeline “B” which, by definition, puts you in a partial update scenario.

Of course, it is theoretically possible that the package was at the same version at point “A” and “B” but most people wouldn’t check that.

not that fresh as you already installed some packages i think? how you do installed paru p.e ?

  • Is this offline install or online?
  • What Desktop is in use?
  • Is the system up to date?

Chrome is only available in the AUR. YAY is therefore required to install it.

One-liner to run an update and then install the package you are looking for based on your selection. It should probably be number 1.

yay && yay google-chrome

best would be to see the full output also not only a snipped.

1 Like

I’ve done that exact command a few times without such an issue. I’ve also done yay -Syy && yay -Yc && yay -Sc after a reboot where I wasn’t sure if an update might cause issues, like pipewire as an example.

My usual full command is yay -Syyu && yay -Yc && yay -Sc when I’m confident that the update I am doing won’t be an issue for my audio or booting. The reason I run the first command after rebooting is to avoid having to download the packages again in case I need to do a downgrade. Saves time.

To be honest, though, I haven’t done a downgrade in a while since I started using BTRFS and timeshift instead. So, I could easily stop doing that command, no biggie. But again - never had an issue.

I’ll take your advice on this, but… “will” is a strong word.

How do you know that? Your system won’t warn you when it is in a partial update scenario. Likewise, not all partial updates will break your system.

That is OK because in this command you are also updating the system.

Although, you shouldn’t use -Syyu for normal updates. -Syy is only required in exceptional circumstances. Using it for all updates puts unneeded load on the mirrors.

To be clear, as an experienced user, you should do whatever you feel is appropriate for managing your own system. I am more concerned that others read these posts and follow the advice without understanding the implications themselves.


I usually update only on weekends, so it should be okay (or even recommended) in my case, right?

It won’t cause the apocalypse or anything but it isn’t recommended. It won’t be useful in that scenario.

The only time it is usually needed is when you switch mirrors and one of the mirrors is broken in some way.

1 Like

Okay. I’ll drop a “y” then. Thanks.

1 Like
  • It’s an offline installation (I update right after install completed)
  • I’m using KDE Plasma
  • Yes

Update: After re-run the update, krunner5 is installed.

I decided to reinstall the OS, twice.

The first re-installation.

Right after installation, when I update the system with

yay -Syu

I got error about krunner5, similar to error with google-chrome (that I DID not have this error with krunner5 before).

It seems wrong, so I re-install the OS again.

I just press Next during each installation step (except partitioning step).
After login to KDE, I update mirror lists and run update. Then krunner5 error appears again.

Here is the full output:

$ yay -Syu
[sudo] password for mimi: 
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 multilib is up to date
:: Searching AUR for updates...
:: Searching databases for updates...
 -> Packages not in AUR: khotkeys  kpeoplevcard  kquickcharts5
 -> Orphan (unmaintained) AUR Packages: krunner5
:: 1 package to upgrade/install.
1  aur/krunner5  5.114.0-1 -> 5.115.0-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
AUR Dependency (1): krunner5-5.115.0-1
:: PKGBUILD up to date, skipping download: krunner5
  1 krunner5                         (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
  1 krunner5                         (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> Making package: krunner5 5.115.0-1 (Fri 22 Mar 2024 04:59:11 PM EDT)
==> Retrieving sources...
  -> Found krunner-5.115.0.tar.xz
  -> Found krunner-5.115.0.tar.xz.sig
==> WARNING: Skipping verification of source file PGP signatures.
==> Validating source files with sha256sums...
    krunner-5.115.0.tar.xz ... Passed
    krunner-5.115.0.tar.xz.sig ... Skipped
:: (1/1) Parsing SRCINFO: krunner5
pub   rsa2048 2016-09-05 [SC] [expired: 2021-09-04]
uid           [ expired] David Faure <>

==> Making package: krunner5 5.115.0-1 (Fri 22 Mar 2024 04:59:13 PM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found krunner-5.115.0.tar.xz
  -> Found krunner-5.115.0.tar.xz.sig
==> Validating source files with sha256sums...
    krunner-5.115.0.tar.xz ... Passed
    krunner-5.115.0.tar.xz.sig ... Skipped
==> Verifying source file signatures with gpg...
    krunner-5.115.0.tar.xz ... Passed (WARNING: the key has expired.)
==> WARNING: Warnings have occurred while verifying the signatures.
    Please make sure you really trust them.
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting krunner-5.115.0.tar.xz with bsdtar
==> Sources are ready.
 -> error making: krunner5-cannot find package name: []
 -> Failed to install the following packages. Manual intervention is required:
krunner5 - cannot find package name: []