Can not install from live no internet

Hey everyone I am new to Linux and am trying to breathe life into my old laptop. It’s a hp pavilion dv2500 i have 4 gb of memory with a 500gb hard drive. a dual core amd turion 64 processor with nvidia graphics and a Broadcom wireless card. I believe my problem may be driver related because my wireless won’t turn on and when I plug in my ethernet I does not detect it. Also when I tried to install the only drive it recognized was the disk drive not my hard drive. If it is fact a driver issue how would I go about installing the necessary drivers with no internet connection? Flash drive maybe?20211014_223348Screenshot_20211014-224924_Gallery

Some ideas:

  • install in offline mode, no internet needed while installing
  • you seem to have an old Nvidia card, so use the default install entry instead of NVIDIA

Could you show the URL that is returned by the following command?

  inxi -Nxxxz | eos-sendlog

Ok I will see what the log says. I did try to install in offline mode but its not seeing my hard drive. It’s only recognizing the disk drive of the DVD I am using to install endeavouros. Booting up into the live session now going to send the log in a few

Edit- here are the results

Could you please give more information about your machine:

inxi -Fxxxz


lsblk -fm
sudo fdisk -l

Are you really using DVD instead of a USB stick?

This might help with wifi:

1 Like

My bios doesn’t allow boot from USB so I had to burn a install disk lol. When I get home I will send you that info.

Edit- here is the info you asked for

1 Like

Ok I am home and got my hard drive working and ethernet working. Now I am trying to install my nvidia drivers and broadcom drivers. I’m am trying to get my wifi running going to keep you posted.

Ok I got to install and got my wifi working. Installed KDE and the screen is bugging out once it boots up16343534212296446958553402336800

Update- I was able to get the system to stop glitching by turning off the compositor.only problem I have Is in the system settings. Sometimes it glitches in there only. Other than that so far it’s very usable and I am enjoying it. Guess I just have a few more tweaks to be 100% good. I think my main problem is still the nvidia drivers for my graphics card. It needs the 304xx driver and I read it’s not supported anymore. Not sure what to do.


Or you could press F12 to disable all desktop effects on kde and see if its better. I would probably not disable compositor unless you want some screen tearing.

If you can run open source driver that would be best. Else there may be some legacy drivers in the AUR that can be installed via yay, but careful with that.

1 Like

Ok checked a couple of other forum threads, that nvidia geforce 7150m is only supported by very old kernel like 4.xx and you are unlikely to make the old proprietary driver work on an arch based distro. Apparently this means your hardware is 10-15 years old, according to this thread it is recommended to upgrade hardware at this point and not worth the trouble…

Unless someone here has better insights.

1 Like

just use the free driver

yes use nouveau-modesetting driver from kernel itself, and may try plasma on wayland with it (installing plasma-wayland-session)

1 Like

Thank you everyone for the responses I will give all that a try a little later and share my results. Yes this is my old laptop from 2007 I believe. My son broke my newer laptop. so I thought why not see if I could breath life into my old one and make a little project out of it. I chose endeavouros to introduce me to arch because I am excited about the steam deck and want to be familiar somewhat with arch before I receive mine. Also I am going to use the steam deck as my laptop replacement. I have some Ubuntu experience from around 2008 as I used to run that on this same laptop we are working on. Anyway just giving a little context. Thanks again and will let you all know how these suggestions workout.

Update- turned compositor back on and instantly started glitching
Pressed F12 and didn’t help. Turned compositor off and rebooted and back to being very usable with minor issues mostly in system settings only.
Only happens when I scroll down on the options to choose from on the left. Doesn’t happen inside of specific options. Other than that it’s pretty responsive and usable for such an old laptop.

Ok I installed nouveau and everything is good now in the settings. I still can’t turn compositor back on. I tried and my screen went crazy. But with it off it works great. Thank you so much to you all for your help and I think my problems for now have been solved.
Edit- when I rebooted its a black screen with a cursor smh guess I messed something up.

Update- think it’s because I tried to install the 340xx driver then canceled the install to install the nouveau fw. Tried to do a fresh install off the disk again but install failed. 16344058452403746385957807142233

Ok got endeavour os back up and running. Had to install zorin to overwrite the hard drive completely and then after that I was able to get endeavour to fully install. Now I’m on a fresh install again to set it up how I had it without the mistake of trying to install the nvidia 340xx driver

Update- got everything set up and working well besides the slight glitches in the system settings and sometimes in the dock but overall it’s tolerable and I’m going g to just run it like this for now. Thanks again to everyone who helped.


This is some dedicated effort to keeping some ancient hardware working. :clap:


Lol its out of necessity some what and curiosity to see how well it will run