Can Not Access BIOS or Boot USB Disk

Somehow the F2 is not getting me into BIOS to modify anything. (tried most tricks I found. ESC, DEL, F10,…)
Another thing (not sure if it is related), I could never boot from a USB though I changed ISOs and flash drives.
I could get by F12 multiple menu having USB drive, when I select it it boots the installed EOS not from USB.

Reading and trying to find out:

[limo@lenovo ~]$ sudo systemctl reboot --firmware-setup
[sudo] password for limo: 
Cannot indicate to EFI to boot into setup mode: Firmware does not support boot into firmware.
[limo@lenovo ~]$ test -d /sys/firmware/efi && echo UEFI || echo BIOS
[limo@lenovo ~]$ 

Does this indicate anything?
How -if possible- I can get

 sudo systemctl reboot --firmware-setup

I noticed many posts everywhere complaining about unable to access BIOS.
What I mainly care now is booting from USB disk as I did before. If I can get access to BIOS that would be much better.
P.S. I installed this EOS from a USB flash drive.
Can any of the above be because I changed kernel to LTS from the default EOS kernel?

Check efi boot order with efibootmgr, set boot order with efibootmgr -o.

Make sure USB boot entry, or equivalent, is first in the order.

As for not accessing BIOS, have you internet searched this with the make and model of your machine?

Once power on it says F2 to enter Bios, F12 for multiboot which gives me the USB disk, when I select it it boots from the installed system.
And yes… I have searched and tried all possible keys(DEL, ESC, F10)

I tried the same USB disk that I installed EOS from, it booted as it should!
The other USBs and ISOs, were similarly copied using

sudo dd if=slax-64bit-9.11.0.iso of=/dev/sdc1 bs=1M status=progress

as I did with EOS ISO.

Is it the distro itself that can’t boot? Does those other USB drives need specific formatting? (I assume dd does everything) :confused:
In this situation, as my EOS USB booted, are there specific distros that can only boot (in my case) and others can’t (like not signed, not certified)?
I found an answer to my question. Yes, some distros can boot and others can’t, still unable to get a precise list that actually boots with UEFI.