Can no longer select i3 on login after booting into Xfce session

Hello, I originally installed Endeavour with i3 + Xfce and used i3 sessions exclusively, but after switching to Xfce to try and fix an issue where all icons changed theme and became low-res I now can no longer select i3 from the login menu. The i3wm packages appear to still be present, but it looks like all Xfce packages and plugins start first on boot.

Can you share a picture/screenshot of your login screen?



Right, here are the relevant parts

The icon beside “gb” in the top-right. Click it please.

That’s where the language icon would be, it just opens the keyboard layout selector. The selector for window managers used to be in the right corner of the password box

I know. I was just wondering it if moved for some reason.

Try reinstalling the packages. It should work.

How did you manage this switching?

I selected Xfce using the button in the password box, there were also options to use either i3 or i3 with debug log. This selector had disappeared after logging out of the Xfce session

Are you using lightdm? Maybe you can take a look at the lightdm.conf.
Did you change one of the hidden files in your $HOME? Where the default session is now set to xfce?

It seems like the issue was indeed with lightdm, since the selector menu appeared as normal after switching to lxdm. Thank you for pointing me in that direction :slightly_smiling_face:
Now to fix the icons somehow…