Can I play Steam games on EndeavourOS?

Why yes…yes you can :wink:

**Warning!** If you do not update your system frequently (one to two days after it asks you to and you have not checked **stop!**

This post is intended to piggyback (link) off of (to) New user guide to EndeavourOS by elloquin . It is also for AMD hardware.

You will need to add the following packages to your install…Don’t worry this is actually easy :hugs:

In a terminal do:

yay steam
select 2 (two) be careful this assumes you haven’t been naughty.
Let the package install. You will be asked a few yes or no questions. If you need help at this point make a reply with the question and copy it and paste it in your answer with three ``` before and after the output. It’s easier to read that way :+1:

Still here?

There will be a few questions on why I recommend this particular Steam package. On my system it has worked with the following packages for Steam games since the day I started using Archlinux…this includes while I was using manjaro.

Almost there :grin:

We only need two more packages :+1:

Number 1

sudo pacman -S amdvlk this is in the official repositories. Thus we use pacman and not yay.

Number 2

yay gamemode

Select 1.

Let it install.

Then do:

systemctl reboot

Go to the application menu and select games (it’s a new entry :joy:)

Launch Steam.

Anything past this is another post. PM me and I’ll do the best I can :hugs:


Why AMDVLK instead of Mesa?

Mesa/ACO has really good performance on anything GCN1.0 and later along with generally more users that have it when finding issues with DXVK. No reason to use AMDs sudo proprietary driver when Mesa/ACO is great on default and for GCN1.0/1.1 is getting a good chunk of love lately.


Because it just works :hugs:

Screenshot from 2020-03-29 18-21-58


but so does mesa and its built into your distro on default no need to install anything else. The only changes required are usually for old GCN cards and thats to enable the newer driver and use RADV and mesa switch to ACO for AMD on default. Old GCN cards (for the moment but thats changing) just need a kernel flag set and youre done


I followed the instructions but I don’t see application in the menu.

Is this guide up to date? I followed the instructions but I dont see steam.

1 Like

The guide is a bit dated now but installing steam has not changed.


Thanks this is the guide I found but the steam application isn’t there. I have a old but capable gpu thats on the list.

  1. Make sure your system is up to date (to avoid partial upgrade scenario)
    sudo pacman -Syu
  2. Other than that just
    sudo pacman -S steam

Should work :man_shrugging:

1 Like

you should actually remove that from the list (or mark it as optional in case of issues with radv). radv has better performance and compatibility. I ran in more issues with amdvlk then with radv on my Vega64.

1 Like

Me too. The post is almost two years old :sweat_smile: Honestly I forgot all about it. I need to get to this as well as the linked guide maybe I’ll just remove them at this point the wiki is much more informative now :wink:

1 Like

yeah. Just remembered that radv is not preinstalled anyway, so sudo pacman -S vulkan-radeon lib32-vulkan-radeon would be more correct.


What game is this?

DOOM :+1:

2016 I think?

1 Like