Can i downgrade OpenGL version?

Hello all! I’m new to this linux things and i have a problem.

I tried couple of distros (Linux Mint, Manjaro) before switched to EOS. My PC is really slow and sometimes i want to play a game but as my pc’s situation, i am not have a lot options to choose. So i was playing a game called “Minetest” with low graphic settings. When i switch to EOS i installed the game and when i opened it, it says im using OpenGL 4.5. With OpenGL 4.5 my computer is having a hard time running the game and the computer’s fan was like in hell. In other distros that i tried, this opengl version was 1.4 and the game was runs with no problem. Its also not just for Minetest, every game that i tried to open, i have the same situation. So, is there any chance to downgrade to 1.4?

First, can you share the output of inxi -Fxxxz so we can what your specific hardware is?

After that, why do you think the problem is caused by the OpenGL version? Are you sure it isn’t some other driver issue?

1 Like
  Kernel: 5.15.33-1-lts arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: EndeavourOS
    base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P5KPL-AM SE v: X.0x
    serial: <superuser required> BIOS: American Megatrends v: 0701
    date: 05/19/2010
  Info: dual core model: Pentium E5200 bits: 64 type: MCP smt: <unsupported>
    arch: Core Yorkfield rev: 6 cache: L1: 128 KiB L2: 2 MiB
  Speed (MHz): avg: 1200 min/max: 1200/2500 cores: 1: 1200 2: 1200
    bogomips: 10000
  Flags: ht lm nx pae sse sse2 sse3 ssse3
  Device-1: Intel 82G33/G31 Express Integrated Graphics
    vendor: ASUSTeK P5KPL-VM driver: i915 v: kernel ports: active: VGA-1
    empty: none bus-ID: 00:02.0 chip-ID: 8086:29c2 class-ID: 0300
  Device-2: Z-Star Micro ZC0303 Webcam type: USB driver: gspca_zc3xx
    bus-ID: 2-1:2 chip-ID: 0ac8:303b class-ID: ff00
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver:
    X: loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.63x7.99")
    s-diag: 338mm (13.3")
  Monitor-1: VGA-1 mapped: VGA1 res: 1024x768 hz: 60 size: N/A modes:
    max: 1024x768 min: 640x480
  OpenGL: renderer: llvmpipe (LLVM 13.0.1 128 bits) v: 4.5 Mesa 22.0.1
    direct render: Yes
  Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:27d8
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.33-1-lts running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.50 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
    driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: e800
    bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 232.88 GiB used: 4.27 GiB (1.8%)
  ID-1: /dev/sda vendor: Samsung model: HD252HJ size: 232.88 GiB
    speed: <unknown> type: N/A serial: <filter> rev: 1113 scheme: MBR
  ID-1: / size: 228.66 GiB used: 4.27 GiB (1.9%) fs: btrfs dev: /dev/sda1
  ID-2: /home size: 228.66 GiB used: 4.27 GiB (1.9%) fs: btrfs
    dev: /dev/sda1
  ID-3: /var/log size: 228.66 GiB used: 4.27 GiB (1.9%) fs: btrfs
    dev: /dev/sda1
  ID-1: swap-1 type: partition size: 4.22 GiB used: 524 KiB (0.0%)
    priority: -2 dev: /dev/sda2
  System Temperatures: cpu: 49.0 C mobo: 32.0 C
  Fan Speeds (RPM): cpu: 942 case-1: 0
  Power: 12v: 11.98 5v: N/A 3.3v: 3.23 vbat: N/A
  Processes: 166 Uptime: 9m wakeups: 0 Memory: 1.92 GiB
  used: 876.4 MiB (44.6%) Init: systemd v: 250 Compilers: gcc: 11.2.0
  Packages: pacman: 870 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.15

this is the output. I am not sure is there is another issue but this is the only thing I can think of that could cause the problem. After this issue i was back to manjaro to check and there is no problem. Since i want to stick with EOS, i am turn back.

Normally, when people have problems like this the first thing we would tryis switching to the modesetting driver by removing xf86-video-intel and rebooting.

However, I am not entirely positive if that CPU supports the modesetting driver or not. It is on the line of where it is supported and there seems to be conflicting information.

That being said, I am wondering if the issue is actually mesa which recently dropped support for some older intel hardware.

So what should i do? Should i remove xf86-video-intel and try the modesetting or maybe i should downgrade mesa version? If so how can i do that?

You can try this, but if it doesn’t work, the GUI may not load. You would then need to reinstall xf86-video-intel.

As a test, you could try sudo downgrade mesa and choose a version 21.3.7.

If that works, you will know mesa is the cause. However, you won’t able to keep it that way. It will be difficult to hold back mesa indefinitely.

OpenGL version on mine is 4.6

Hello, ı downgraded mesa version to 20.3.4 and its fix the issue. Now its seems to switched OpenGL 1.4 and there is no other problem. Thank you very much. But why do you said “It will be diffuclt to hold back mesa indefinetely” ? It will bring some issues in the future?

Absolutely. Arch-based distros are rolling. You can’t hold software back for long periods of time. I just won’t work as other libraries start changing. The system needs to roll as a unit.

Now that you know Mesa is what was causing the issue. The next step is to use that information to see if there is a workaround for your hardware.

I see, well it seems my problem solved for now and, again, thanks for the time you took for me.

Well, i encountered an issue after downgraded mesa package. Now steam games don’t launch. When i upgrade mesa to latest release games launch properly but this also means OpenGL 4.5 again and my pc dying when running the games. I guess its just time to buy a newer hardware ha.

Update to latest mesa again and try to play around with env vars.

E.g. try running:

1 Like

Hello, thanks for your response. I updated to latest mesa and typed:


This is downgrade to 1.4 and game opened. But performance is nearly still as bad as 4.5 version of OpenGL.

I am fairly certain that 1.4 is the highest your card supports. I really think the OpenGL version is a false flag here.

I suspect that the reason it “drops to 1.4” is that your card is properly supported by mesa so it knows how to set it. But when you roll to the latest version you card becomes unsupported and you may be falling back to some kind of software rendering. In this case, changing the OpenGL version doesn’t make much difference.

My advice would be to see what others with i915 GPUs are doing. Perhaps there is an alternative you can use.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.