Can Gnome limit battery charging?


In Windows my LG charges to 80% in order not to stress the battery. However I spend most of my time in EOS and usually plugged into a dock. As a result my battery sits at 100% most of the time.

It is impractical to remove the cable as it drops performance and also disconnects my keyboard/mouse/screen.

I need to be able to be plugged in most of the time, so I was wondering if there is any way Gnome can limit the level of battery charging to X% (where X is something I can configure)?


Not too sure if you can do it in GNOME but on my old laptop I could set it in the BIOS as always plugged in and this stopped the battery fully charging

Maybe you could consider this tool that I have used with success on the Lenovo E580.


I did it in the command line and edited with vim but it seems a graphical user interface is possible:

1.2 Front end

  • tlpuiAUR is a GTK user interface for TLP written in Python.
  • slimbookbatteryAUR is a different GTK interface that works with additional drivers like AMD and NVIDIA.

This is the part I used in the command line:
2. Configuration

The configuration file is located at /etc/tlp.conf and provides a largely optimized power saving by default. For a full explanation of options see: TLP settings.

Cheers! :wave:

1 Like

Actually I have discovered a vendor-specific way to do this. I found that there’s an LG kernel driver that exposes this - and other - features and I found the EOS kernel has it. So I simply created this systemd service to run at boot:

$ cat /etc/systemd/system/lg-battery.service
Description=LG Gram battery charge threshold service



All the script does is:

$ cat /usr/local/bin/ 


echo $BT > /sys/devices/platform/lg-laptop/battery_care_limit && \
  ( echo "Set battery charge threshold to $BT..." ; exit 0 ) || \
  ( echo "Failed to configure battery charge threshold!" ; exit 1 )

I’ve discharged to 75% and am simply waiting to confirm that it will stop charging at 80% but it seems like this is going to work.

EDIT: Seems like it worked, settings even shows “Not charging” status with a charge level of 80%. Waited a while to make sure it’s truly not charging and the level has remained 80%.

Really appreciate whoever wrote this driver. It even lets you control reader mode, USB port charging, fan control…

@Epictetux Appreciate your suggestion as well. Will stick with this for now.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.