Can EndeavourOS and Windows be installed on 2 different drives?

Hello friends.

I installed EOS and W10 sharing the same SSD, installing W10 first, and then EOS with “Replace a partition” installation option.

So the EOS GRUB allowed me to start EOS or W10 every time I start the pc.

Is it possible to do this by installing EOS and W10 on separate drives? (For example EOS on sda and W10 on sdb).

And if possible, in what order should it be installed?

I tried to try out of curiosity and install W10 first on sda and then EOS on sdb, but GRUB did not show up with the W10 option.

I tried the other way around, and it didn’t work either. I’ve been thinking that maybe my EOS (sda) was installed with GPT, and W10 (sdb) was installed with MBR by default. Could this be the problem, or is there something else?

Thanks in advance.

I think that’s because you’re booting into the drive that only has Windows installed. In order for the system to see EOS, you have to boot with the second boot device (the drive with EOS installed). It’s like when you’re trying to boot into a live USB, you have to press some key to activate the boot menu in order to select the usb stick as your boot device if you haven’t reordered your boot priorities in the BIOS. Once you selected the device, only then will the boot loader screen show.


are you really using grub or systemd-boot (the new EndeavourOS default?)
For grub, you need to enable osprober to get an entry for Windows.

For systemd-boot you need to do some manual steps:


That is the preferred method.

Did you add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub and updated grub after?


There actually a few ways to accomplish that,

Typically Windows first. But that’s not really a requirement.

If Windows is installed in UEFI mode (you’ll have a small partition including *.efi files for Windows boot), then it is best install EndeavourOS also in UEFI mode. And use GPT partition table for both disks.

If UEFI mode is not supported by your machine (=old machine), then you’ll install in legacy BIOS mode. Then it is easier to install Windows first. And easier to use msdos partition table for both disks (gpt is also possible but requires an additional small partition for the MBR).

1 Like

Yup, absolutely, this is the easiest way to dual boot too.

Just install each on their respective drives. If you want eos grub to see it, turn on os prober or whatever the system d variant is.

And then just double check that Linux boot is first in the list in firmware.


Thanks friend, I have sda first (EOS), and sdb second (W10) in the BIOS boot menu of the motherboard, sorted.

Thanks friend, my motherboard is very old, it’s a gigabyte H61M-D2H-USB3, EOS only allows me to activate GRUB, system-d doesn’t show up during my EOS installation.

Thank but, I just looked at that file, and found this:

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.

Thanks for answering. Windows was installed with MBR (dos) partition table, by default (won’t let me choose partition table type during Windows 10 partitioning/installation), and then I installed EOS with GPT partition table.

At least I think so, because:

Disk /dev/sda: 223,57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: CT240BX500SSD1  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: D1FE8994-289B-455B-BCDE-4814D6664A55

Device        Start       End   Sectors   Size Type
/dev/sda1      2048  33556479  33554432    16G Linux swap
/dev/sda2  33556480 468856991 435300512 207,6G Linux filesystem

Disk /dev/sdb: 223,57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: KINGSTON SA400S3
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6c422d40

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sdb1            2048 467759885 467757838  223G  7 HPFS/NTFS/exFAT
/dev/sdb2       467761152 468856831   1095680  535M 27 Hidden NTFS WinRE

Thanks friend, sorry I’m new to Linux, I don’t know what os-prober is, but my motherboard is very old and it only allows me to install GRUB during EOS installation.

Although I can create GPT partition tables.

You need to uncomment that line, remove the # save the file. Make sure os-prober is installed and run sudo grub-mkconfig -o /boot/grub/grub.cfg

You should see that it found windoze in the output of that command. Now when you reboot windoze should be in the Grub menu.

1 Like

Your motherboard is getting dated for sure. As long as it still works and you are satisfied with it’s capabilities then that’s all that matters.

Just follow what @BendTheKnee has posted above and you should be able to get Windows added to the grub menu.

1 Like

Your motherboard has no impact on when you can install grub. You can install or reinstall anytime you want via chroot. Just an FYI.

1 Like

Until recently I had a computer with both on two separate drives. I didn’t even use grub to switch, I would literally switch in firmware when I wanted to use it.

1 Like

Thanks friends, but I removed #, saved the file, checked if os-probe is installed:

extra/os-prober 1.81-1 (17.4 KiB 57.8 KiB) (Installed)
    Utility to detect other OSes on a set of drives

I did:

sudo grub-mkconfig -o /boot/grub/grub.cfg

I put the password.

I obtained:

Generating grub configuration file ...
Found background: /usr/share/endeavouros/splash.png
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...

And I rebooted, but Windows 10 doesn’t show up, just EndeavourOS, and another EndeavourOS option below, those 2 options have always been there.

Did you change the entry from true to false also?


Then run the update grub command.

Edit: Maybe it’s already set to false. :wink:

1 Like

Yes correct, it is “false” by default.

I am going to format EOS with MBR (like W10), I want to check if that may be the problem, and if the problem persists I will do these steps again for the GRUB files.

I will be back as soon as possible!

the future proof approach would be to repartition everything with a GPT partition table.
MBR is ancient and support for it is beginning to being dropped.
Be aware that you won’t be able to keep data while changing the partition table, so make backups

1 Like

@nicknick is running a bios machine from yesterdays past. It has no efi.

1 Like

I’m back. I formatted EOS with MBR partition table, and modified the 2 GRUB files, but it still doesn’t detect W10.

I think the problem is that this works only for GPT partitioned disks, as you said.

So, I have to make W10 not create an MBR partition by default, and I have to do that from the W10 CMD terminal (at least I saw that in a tutorial).

When * appears under GPT tag in W10 CMD, it will be converted to GPT, and then you need to close CMD and continue W10 installation.

Anyway, I just wanted to know if it was possible to do this, it’s really not something I need 100%, I’m very happy with EOS, so I reformatted with the GPT partition and I’m left with just EOS.

Also, I’ll format the other SSD to ext4, to make it more compatible with EOS.

I highly doubt I’ll ever need to use W10 again, unless there’s some game I really want to play that doesn’t work on Steam, until then, I don’t need W10.

Thank you all for your help guys, I’m sorry I didn’t fix the problem, but I don’t feel like reinstalling W10 for now, but I’m going to mark the answer as “solution” because that may help someone to get it working.

(By the way, I don’t know which answer to mark as correct, because you are all right)

(Example image):

Just to make sure we’re covering all bases here. Did you make sure you have Fast Boot or Hiberboot disabled in windows 10?

1 Like

Yes friend, if I remember correctly I disabled fast startup + hibernate + sleep + turn off screen after 5 minutes + hibernate after 15 minutes, in W10.

I didn’t use the powercfg.exe /hibernate -off terminal command, but I assume it works the same through the W10 GUI.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.