Camera not working after install, probably pipewire

I have this problem with Skype, VLC, Cheese, anything I test.

Cheese got me this error:

(cheese:12480): cheese-WARNING **: 06:17:38.909: Internal data stream error.: ../gstreamer/subprojects/gstreamer/libs/gst/base/gstbasesrc.c(3127): gst_base_src_loop (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin35/GstPipeWireSrc:pipewiresrc1:
streaming stopped, reason not-negotiated (-4)

list cameras

ls -ltr /dev/video*
crw-rw----+ 1 root video 81, 1 07-04 05:45 /dev/video1
crw-rw----+ 1 root video 81, 0 07-04 05:45 /dev/video0

Having trouble pasting logs

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0 4297k  100   192    0     0    238      0 --:--:-- --:--:-- --:--:--   238
<head><title>413 Request Entity Too Large</title></head>
<body bgcolor="white">
<center><h1>413 Request Entity Too Large</h1></center>

What’s my next step?


If you’re trying to use Gnome Cheese from the Arch repos, it’s been somewhat broken on Arch for some users. I’ve talked to upstream since Gnome 40 to find the cause to fix it, but nothing so far has worked. The only solution that does work for users is if you use the Gnome Cheese flatpak (seen here on Flathub) then you’ll be able to access your camera just fine. If you’re not using Gnome Cheese, then by all means please ignore this post, but hopefully it’s helpful.

@Scotty_Trees I tried Cheese because it was suggested as a test tool, initially I had problem with skype, camera does not work.

@edit: Trees Same thing happens on manjaro, both gnome and kde so its an arch thing :frowning:

tried what will be installed per default already and is also on our wiki ?

v4l2-view ( a simple viewer) and v4l2-test-bench a qt-based config tool
These are the test tools you should use… they can also be used to set configs for the camera and they will get applied so you have these changes also if you would use skype or such…

skype web is working here:

Thank you, that was my starting point.

I suppose it’s a hardware problem, it persists on every install, pop os, manjaro, mx linux and endeavour. Didn’t happen before.

v4l2-ctl --list-devices
shows the device?