Calamares not working

When I boot into the installer, everything is fine.
I partition my SSD and HDD as needed, and connect to the WiFi.
Then I start the installer, and select install, and select online. It would load calamares when I was testing it on a VM, but it didn’t start. I ran sudo calamares from the terminal, and it complained about some missing settings.conf in /etc/calamares/. I cdd into that directory, and found settings_online.conf, and two other similar files. I symlinked it as settings.conf using ln -s, and also 2 other files (welcome and pkglist) with a _online suffix, without the suffix. I again ran sudo calamares, and it started without errors. I proceeded with manual partitioning, and it started the install. It initialized pacman and copied the keyring etc… and it showed an error with pacman, stating that it failed. some <pre>pacman</pre> failed error.

The same error repeats whether I use ventoy or I flash it directly.
How can I fix this error and install endeavourOS?
Or if not possible, I am ready to pacstrap. Just want to know the packages to install, and other extra steps.

This will break it. The only online file you should copy/symlink is settings.conf.

If you want to run Calamares manually from the ISO, I would reboot so you have a clean setup and run these commands:

sudo cp /etc/calamares/settings_online.conf /etc/calamares/settings.conf
sudo calamares -D8 | tee ~/endeavour-install.log

If you don’t have the install log in the right location, the installer will fail at the end.

1 Like

I tried without symlinking welcome.conf and pkglist.conf, as u said, but same error

Please reboot to a clean ISO and run the exact commands I posted.

If it doesn’t work, please share the full output here.

Those are the commands I use to test Calamares during development so I would be pretty surprised if they generated a config error.

Thanks, that’s good to know. I can see that saving me some time.


Finally, installed without errors