Calamares closing

I can’t install the system, the calamari installer closes shortly after it’s opened.

The log:

  • First welcome here!
  • Second sorry that install is not working for you like it should.
  • how do you burn/create the install media?
  • is secure boot disabled?
  • what is on /dev/sda2 ?
  • what is the setup you want to install, harddisk wise? Erase the HDD ? If you want to use the whole HD for EnOS please use partition tool to clean the disk before starting installer.

Thanks for the reply.

  • I create this media with the rufus.
  • Secure boot disabled.
  • /dev/sda2 is a windows partition
  • I will make a dual boot with windows.

Well, I keep forcing the calamares to close several times and after a lot of insistence it worked.

This has only happened twice so far, and believe me, there have been several attempts to do it.

I will test this tip about using gparted before opening the installer.

Start the installer and the installation did not work. It completely locked my computer at 23%.

Also: the gparted tip not worked too.

To have more details about the case, could you do the following steps:

  • in the installer (before installing anything), start a terminal and install inxi and show here the output of terminal commands:
yay -S inxi
inxi -Fxxxc0
lsblk -fm
sudo fdisk -l

My guess based on current info is the USB stick may not be properly written. The most reliable way to do that is to use program dd:

sudo umount /dev/sdX
sudo dd status=progress bs=4M if=/path/to/endeavouros-xxx.iso of=/dev/sdX && sync

where X refers to the USB drive (shown in the output of lsblk above).

You just need to be extra careful to choose the right value for X, otherwise you will overwrite a wrong disk!

The progress bar usually seems stuck at this point (be patient).
It’s when you need most of your processor, would be nice to know if you have a good processor or if you’re trying to run multiple things while running the installer, like opening a browser and watching a youtube video etc.

The output of the commands

I tried: rufus, balenaetcher and dd
Same error for all.

it’s not just the installer who stops, everything stops working. The mouse, keyboard, nothing answers more. I had to force the computer to shut down.

The error log is practically the same in all installations.
This is always at the end of the file:

12:41:04 [0]: QDBusError("org.freedesktop.DBus.Error.NoReply", "Message recipient disconnected from message bus without replying")
12:41:04 [6]: Remaining modules: 1 
12:41:04 [0]: "Message recipient disconnected from message bus without replying"

Now it did not stop at 23% but remained at it at 87%:

Running operation update_system

I’ve been waiting a few minutes and nothing changes, I don’t think it worked again.

Is it possible to remove the big drive (sdb) and then try to install?

Your machine specs seem OK and should be possible to install linux.

My only small concern is that sda is a gpt disk, and sdb is a mbr disk. That’s why a simple test of unplugging the sdb drive and install without it. I guess you are trying to install to sda3 partition.

I reckon you’re hitting the same issue that I did. System Update Speed

1 Like

hello, the most critical moment in the installation, it is partitioning especially in uefi the rest one must wait

1 Like

That might be the reason.
The current mirrorlist in the installer may not be optimal for your location.
To fix that, you can use reflector to fix your mirrors.
You should select mirrors (and mirroring countries) that you know should be up to date and fast.
Usually the closest mirrors are the fastest, but also important is that the mirrors are up to date.
So you could try this command in the installer before starting the install:

sudo reflector -a2 -phttps -f10 -l20 -c"YOUR COUNTRY" --save /etc/pacman.d/mirrorlist

Then check the list of mirrors in file /etc/pacman.d/mirrorlist. If there are reasonlable mirrors, proceed to install.
If the mirrors are not OK, add a close neigbouring country (that has good mirror servers) with option


Note that names with spaces need quotes.

With command

reflector --list-countries

you’ll get a list of supported countries.

You can just wait or in a next attempt poweroff internet before launching calamares, then it will jump update_system module.

I modified the list of pacman mirrors before the installation but then it was updated again with only one mirror.

I did this, I removed the network cable even during the installation, it worked very well.

1 Like

So, finally everything’s settled.

After mounting the partitions of my other hd (sdb) the installer didn’t close anymore.

  • Installation stopped at 87%

I removed the connection to the network and updated the packages after the first boot (btw, I think this could be a user’s choice, update or not the packages during the installation)

Thank you all for your help!

1 Like

I’m glad you managed to install!

Yes, the module is removed for the next iso release, update will be availale after install when first booting the system.