Buggy widget theme freezes plasma on KDE start

Hi all,

A very happy EOS user for the last couple of months!

Yesterday I made the move from the default XFCE to KDE, and everything went fine.
This morning I was playing with desktop widgets, and chose the network widget which I placed on my desktop. Looking at the settings, I found extra themes for that widget and installed one. Upon trying it, my whole desktop froze except for the cursor, and after 1 minute or so turned black, with only the cursor visible and moving.

I Ctrl-Alt-F2 to a tty session and tried to find the offending widget to delete it but couldn’t.

A restart does nothing: after a few seconds the widget fires up and the buggy theme freezes everything again.

(using the latest kernel and nvidia drivers, both from repos)

Thanks for any help!

I had no luck finding a way to delete a KDE widget from the terminal via a quick search, but it may well be a possibility. There are plenty of KDE wizards around here, so they might be able to help. Other than being quick to remove the widget before the freeze, the only thing I can think of is deleting the offending theme completely. Hopefully that’s an option.

1 Like

When your Desktop Manager (sddm or lightdm) comes up, do not log in. Press Ctrl-Alt-F2 and log in as root. Then see if you can reverse whatever was done to install buggy Widget.



Thanks for all the comments.

So I solved it like this:

Open a new tty (Ctrl+Alt+F2) and from there either edit /home/.config/plasma-org.kde.plasma.desktop-appletsrc or just rename it to something else (which is what I did).

Restart the computer and you end up with a new, default configuration. From there either accept the default and rebuild your desktop/widget preferences, or uninstall the offending new theme, restore the file above, and restart (which is what I did).

Credits to: