Bug Report: EndeavourOS Welcome can't be turned off

After the update the other day the Welcome app pops up every time I log in.

I have both closed the app with the “Don’t want to see this again” button AND used the console command to disable it. Neither works.

1 Like

@manuel mentioned that it was recently changed to this behaviour (not sure why).

I (on i3) just changed the --enable option to --disable in the exec line of /usr/share/applications/welcome.desktop and it’s not popping up anymore.

edit: actually putting --disable there is an overkill, just removing --enable should be enough.

That does not explain my problem.
I don’t touch the launcher. It auto starts every time I log in despite having both manually and by clicking the button on it have disabled it.

Again, I have not touched the launcher, at all. I know I can just remove the command manually, but I shoudn’t have to. This is a bug report, basically.

(Edit: I just now went in and looked in Session And Startup (I run Xfce) and lo and behold: The Welcome app was, despite me having disabled it again in the terminal, checked in the list of autostart programs. I now unchecked it there, let’s see if it keeps it from starting or if I simply have to uninstall the program).

…That did it.
So, the way I could turn off the EOS Welcome app was by going into Session and Startup in Xfce settings, uncheck the Welcome App there under Autostart options.

It did NOT work editing the launcher, which is no surprise since it started without the launcher.
It did NOT work to click the button in the window saying “Don’t show this again”.
It did NOT work to set it as “Disabled” in the terminal.

With all of those settings it still auto-started every time.

Just to add my 2 cents: if there are no GUI tools for controlling startup apps, removing welcome.desktop from ~/.config/autostart may do the job too.

But overall I agree that the user shouldn’t have to jump through hoops in order to disable the app.

1 Like

glad you brought that up, as it happens to me as well since a couple of days. selecting “do not autostart” has no effect, unfortunately. also, there is no entry in plasma autostarts.

another little issue: the update notifier appears 2 times in a row for some reason, so i am blessed with quite some pop ups after all :wink:


Thanks for the reports!

The welcome launcher files incorrectly included wrong options, --enable was also in autostart and shouldn’t have been there, sorry about that.

I’m currently fixing it, and it will be available soon. New version is 2.4.43-1.


I see it in my /etc/xdg/autostart/welcome.desktop, but not in ~/.config/autostart/welcome.desktop :thinking: Then actually removing it from user-specific directory may make things worse since it will fallback on the system-wide autostart configuration by default?

Did you receive the welcome update yet?

And what do you have in ~/.config/autostart/welcome.desktop?

Just got the welcome 2.4.43-1 :smiley:

I already removed it for testing :confused:, but there was no --enable option for sure. For me getting rid of the --enable in the launcher worked, maybe because i3 autostarts apps itself (I didn’t touch the exec --no-startup-id sleep 15 && eos-welcome line in the i3 config.

1 Like

OK, great that it works now. :smile:

1 Like

all good now, thanks @manuel.

1 Like

Would you please create another thread for the eos-update-notifier? We can solve it there, and it may be better for others having the same problem to create an own thread for it.

Yep, it works just fine. But I seem to have another problem. A serious one… Being dumb that is :sweat_smile: Nothing was maliciously autostarting it for me. I have

command=gtk-launch welcome.desktop

in my i3blocks. I think it was re-enabling the welcome app every time I was launching it, despite me disabling it from the terminal. Since I reboot rarely, I didn’t have much chance to notice that this behavior is not constant. Then I was too busy hunting down this ‘bug’ :smile:, that I disabled it in the launcher. After that it’s just been plainly unable to launch at all, I guess. Ok, the update brought --enable back to the launcher, but now I am prepared better :sweat_smile: Going to hit “Don’t show it anymore” every time after launching it, or, even better, just launch it via a shortcut and getting rid of the ‘exec’ at boot (this i3 config is still very fresh).
Thanks everyone, still learning :slight_smile:

Did I understand correctly that you still have some problem with the welcome launcher?

If so, then probably you should hunt down all welcome launcher related welcome.desktop files, or other files that may start eos-welcome either directly, or indirectly.

Commands for searching could be something like this (for welcome.desktop):

find $HOME -name "welcome.desktop"
find $HOME -type f -exec grep -l "welcome.desktop" {} \; 
find /usr -name "welcome.desktop" 2>/dev/null
find /usr -type f -exec grep -l "welcome.desktop" {} \; 2>/dev/null
find /etc -name "welcome.desktop" 2>/dev/null
find /etc -type f -exec grep -l "welcome.desktop" {} \; 2>/dev/null

Note that some of the commands above take a lot of time…

1 Like

I don’t think it’s a problem. The [welcome] entry from my i3blocks.conf launches the welcome app via it’s .desktop. Which has--enable in it, so it’s re-enabled every time I launch it and then it gets started at boot, because of the ‘exec’ in my i3 config. So, if I disable it with eos-welcome --disable, launch the gtk-launch welcome.desktop (via i3blocks) and close it normally via a shortcut and reboot it is autostarted at boot. It’s not an issue now, I just got confused by it before.

edit: the welcome.desktop that seems to get executed is in /usr/share/applications/welcome.desktop

1 Like

Yes, that one is designed to always --enable welcome.
The other one is /etc/xdg/autostart/welcome.desktop that should not --enable welcome.


maybe I should, but it’s just not consistent enough. today it did not occur.? and, tbh, it is not a major drawback :slight_smile:

i vaguely remember a manual workaround for this kind of issue, which i once applied already…

1 Like