[BUG]: Calendar in the Budgie top panel menu does not open the Gnome Calendar application

Not sure why, but clicking on the date in Budgie top panel and then clicking on Calendar does not actually open Gnome Calendar as expected, but instead opens the basic Text editor.

I am not too sure if this is a problem, or my own personal setting of some kind, but thought I’d mention it here just in case.

Thanks,

1 Like

I am also having the same problem

I will install this DE and try to reproduce it.

Reproduced!

  1. Click on the time
  2. Click on Calendar in the dialog
  3. Edit Text file :upside_down_face:

https://www.archlinux.org/groups/x86_64/gnome/
is installed per default on budgie and includes gnome-calendar
Configuration is default what comes with packages from Archrepo… may something is missing a package needed to implement it?

The texteditor is set as default calendar after install.

I have the fix:

~/.local/share/applications/mimeapps.list must contain:

[Default Applications]
text/calendar=org.gnome.Calendar.desktop

then it is working for me!

Ist this working also for you @Maggie @Halcek?

2 Likes

@Alpix As per your suggestion, i added the mentioned lines to /.local/share/applications/mimeapps.list and now it opens calendar app correctly.
PS:The file /.local/share/applications/mimeapps.list was empty when i added those lines.
Thanks

1 Like

I wish we could also have the settings to add desktop folders as it is on Solus budgie. :wink:

Works like a charm! Much thanks. :clap:

I also recommend putting the mimeapps.list file into ~/.config as that way it’ll affect all the users and not just the current user. Perhaps this file could be added during the default installation too @joekamprad, or @Bryanpwo?

Much thanks,

1 Like

Currently we do not ship any settings to DE other then XFCE4.
But it will be possible in a future release, or as an option with welcome app on first boot.