Btrfs Assistant 1.0 is coming, testers needed

There are things selected. You are running a btrfs balance weekly and a scrub monthly.

Lots of good info in the thread I created, but this had to do with this app and things related, so I figured I’d ask here.

Does it matter the order I install the following apps so that the auto configuration that snapper-support and whatever else does works correctly?


I was going to install these apps, then make a snapshot so I could see the grub file get updated, then do:

sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo systemctl edit --full grub-btrfs.path

Replace file contents with below


Description=Monitors for new snapshots




sudo systemctl enable grub-btrfs.path
systemctl start grub-btrfs.path

I figured I would post all of this, maybe make easier for someone else, even though I know this all works, just wasn’t sure all of what snapper-support configured for me, especially since I ran it after configuring quite a bit myself in my test VM.

If you are going to do all that, don’t install snapper-support.

There is the easy/automated path which is install btrfs-assistant, btrfsmaintenance and snapper-support.

Or the manual path which is do all the things you mentioned.

snapper-support installs and configures grub-btrfs, snapper and snap-pac. It should also create and enable the unit file for you.

To answer your question it doesn’t matter the order they are installed.


I’ve been following this thread for a long time now, and it seems more and more interesting. Me being a lazy sod, would benefit greatly from this assistant.

After my impending move to a new appartment/flat, I’m going to try it my Arch laptop, witch I bork much more often than I do EndeavourOS (never happened). Tinkering might be the culprit… not me. :laughing:


Nice. Thanks. So I won’t do all of that then. I’ll just install snapper-support. :grin:

Well, I am still testing and learning!
I made a little script I called checkpdf to find corrupted PDF files. A Script to Find Corrupted (move/delete/..) PDF Files - #2 by limotux

Running it without specifying a specific folder seems to search ALL folders but returning results from some folders I know nothing about, and reporting some corrupted PDF file I am sure I did not put them, I did not even view them.

The PDF file here is mine but I do not know what that folder is:

/proc/10295/task/10295/cwd/zzz borken 2_1.pdf is OK

Now, my question is, are those “strange” folders, subfolders snapshots of my /home? system? snapshots of system? Installed by system or an app I installed?
Is it safe to delete these corrupted files in these strange folders?
I am still keeping my script to just display and not move or delete any files because I am not sure what are they.
P.S. Files named numbers are mine like “2_3.pdf”. Others I know nothing about them!
I care about removing corrupted files from previous snapshots of course. How to?
Here is a sample:

home/limo/zzz borken 2_3.pdf is OK
/home/limo/zzz borken 2_4.pdf is CORRUPTED
/home/limo/zzz borken 2_5.pdf is CORRUPTED
/proc/10295/cwd/zzz borken 2_1.pdf is OK
/proc/10295/cwd/zzz borken 2_2.pdf is OK
/proc/10295/cwd/zzz borken 2_3.pdf is OK
/proc/10295/cwd/zzz borken 2_4.pdf is CORRUPTED
/proc/10295/cwd/zzz borken 2_5.pdf is CORRUPTED
/proc/10295/task/10295/cwd/zzz borken 2_1.pdf is OK
/proc/10295/task/10295/cwd/zzz borken 2_2.pdf is OK
/proc/10295/task/10295/cwd/zzz borken 2_3.pdf is OK
/proc/10295/task/10295/cwd/zzz borken 2_4.pdf is CORRUPTED
/proc/10295/task/10295/cwd/zzz borken 2_5.pdf is CORRUPTED
/proc/1140/task/1140/cwd/zzz borken 2_2.pdf is OK
/proc/1140/task/1140/cwd/zzz borken 2_3.pdf is OK
/proc/1140/task/1140/cwd/zzz borken 2_4.pdf is CORRUPTED
/proc/785/task/72452/cwd/zzz borken 2_5.pdf is CORRUPTED
/proc/785/task/785/cwd/zzz borken 2_1.pdf is OK
/usr/share/cups/data/secret.pdf is OK
/usr/share/cups/data/standard.pdf is OK
/usr/share/cups/data/topsecret.pdf is OK
/usr/share/cups/data/unclassified.pdf is OK
/usr/share/cups/ipptool/document-a4.pdf is CORRUPTED
/usr/share/cups/ipptool/document-letter.pdf is CORRUPTED
/usr/share/cups/ipptool/testfile.pdf is CORRUPTED
/usr/share/doc/ghostscript/GS9_Color_Management.pdf is OK
/usr/share/doc/graphite2/api/refman.pdf is OK
/usr/share/doc/ijs/ijs_spec.pdf is OK

That has nothing to do with btrfs. It looks like you are running your script against the entire system. Either target the script to only run against the locations you store your pdfs or exclude the parts of the system you shouldn’t be searching.

You should also consider that just because a file ends in ,pdf doesn’t actually mean it is a pdf file. Especially when you search system locations.

Thanks a lot @dalto
I did not attemtpt searching system files. I am still learning.
So I will (try to) modify the script to search only with a /home/ path.
Thanks a lot.

My understanding of Sanpper and snapshots taken, is that I can boot through Grub menu (the last option down Grub menu), which gives me a list of snapshots taken.

I am supposed to scroll down and select an earlier snapshot to boot to.
I tried this but I am not sure I really booted to the selected snapshot. I did not get a message to login to BTRFS Asistant to restore the system to that snapshot as happened with me wit TimeShift.

Am I doing something wrong or missing something in settings?
Just read something about snapper-rollback is this what I need?

Btrfs Assistant doesn’t try to detect that situation. You need to open it to restore the snapshot.

Make sure you don’t boot off a snapshot and then use your system normally.

100% no

Btrfs Assistant has a restore section.

:hushed: :astonished:
I thought booting to a an earlier snapshot, updating then taking a new snapshot is enough!

So, what is booting to a snapshot specifically dedicated to? What are the limits, do and do not?

OK, I could not boot to an earlier snapshot anyway. (assume I broke the system and it is not bootable anymore, I assume I can boot to an earlier snapshot and restore some working snapshot - maybe updating the system and taking a snapshot would later reboot to this “new” snapshot)

Isn’t this applicable only in case I could boot to the system or a snapshot that has BTRFS Assitant installed?

When you boot to a bootable snapshot through GRUB, you’re doing it in read-only mode. You would notice that you couldn’t do some things, like install apps, etc. Once you get system booted, you can then do a snapshot restore for real to whatever snapshot version you want.

Thanks @nVIceman
This clarifies lots of things.

But still, I could not boot to a snapshot!

This is only true if you haven’t installed the hook for the overlayfs. You should if you haven’t.

What happened when you tried?

Never heard of it.

Nothing! It just boots normally as if I just booted the default way (first menu item in Grub). It did not try to log me in BTRFS Assistant or whatever to restore a snapshot.

Did you read the solution above?


1 Like

I quickly went through both of them. Though they look so techie for me, I found yours @Zesko a bit simpler to understand (somehow).

As I remember I haven’t installed grub-btrfs-overlayfs. Should I install it?

I see… I should follow your post step by step from the begining to the end to be able to boot to a previous snapshot, detect I booted to a snapshot, restore to this snapshot!

No, you have it, because “grub-btrfs-overlayfs” has already been included in grub-btrfs.