BSPWM - login loop

After resolving one issue, here is another. Tried few DE for some period, after some reading i started to like idea of WM.
Tried BSPWM - community edition, from installer. Problem is, when I type my password, there is a black screen with underscore for few seconds, and I am back to login screen. Tried with ctrl alt f3, and i logged successfully. From there i tried with startx, which gives me some white windows (terminals). To be more precise, 3 of them. And that’s all. After that tried to run bspwm from terminal which leads to series of errors. Then tried to run startx & bspwm which again opened 3 white terminals and popup from EndeavourOS welcome app.
This is fresh install. Same happened when i tried to install it alongside gnome.

Do you have another DE? You need to create/set your screen resolution with ArandR/xRandr and name the file monitor.sh in ~/.screenlayout/

It should be something like this

#!/bin/sh xrandr --output LVDS1 --primary --mode 1366x768 --pos 0x0 --rotate normal --output VIRTUAL1 --off --rate 60

Booting LTS Kernel might also work (works for i3, I don’t remember if it was working for BSPWM)

No, only fresh install of BSPWM. On login screen everything is fine.
How am i supposed to open ArandR? From ctrl alt f3 or?
Thank you for your reply

Well ArandR is GUI based, what connector are you using? Is it desktop or a notebook? What’s your screen resolution?

EDIT : Run xrandr from TTY and post the output if you can (I’m interested in the connection interface, if it’s hdmi, dpi or else and screen resolution)

It is a laptop with 1600x900 resolution. As i described, no gui is shown. Only login screen, where when i type password i am back again at login screen.


This is what’s shown after running startx and bspwm

Okay then, login in to a TTY (CTRL+ALT+F6 to open tty then login)
Then type sudo mkdir ~/.screenlayout to create the necessary directory
after that sudo nano ~/.screenlayout/monitor.sh
and copy this script

#!/bin/sh xrandr --output LVDS1 --primary --mode 1600x900 --pos 0x0 --rotate normal --output VIRTUAL1 --off --rate 60


Let me know how it goes :smiley:
I’m gonna make a coffee ^^

@Dev0ut might be same as last one … lts.

1 Like

Yup, it’s the same issue

1 Like

would be nice find out why . understand people just want working system

Edit … did you try install bspwm after you install working gnome or install both at same time ?

Tried it with, unfortunately no success. While it doesn’t show errors from previous image, it just say waiting for xserver to shut down.
Just in case tried another distro with bspwm and same version of kernel and it is working as expected.

Oh, okay, then install the LTS kernel

sudo pacman -S linux-lts
sudo pacman -S linux-lts-headers
then regen grub with
sudo grub-mkconfig -o /boot/grub/grub.cfg

reboot

P.S. You might want to delete ~/.screenlayout/monitor.sh IF it gives an error with LTS kernel

2 Likes

Will try that at morning, atm i do not have ethernet connection :confused:
What is actually causing issue? Why lts kernel is probably going to resolve this? Just want to learn, everything is new to me.

Well the issue for me was that when I’ve installed the i3/bspwm (xfce4 was working fine) I got instabooted to login screen just like you, I’ve solved that by installing the LTS kernel which allowed me to login (I presume the autodetect of the screen works on LTS and it’s broken on the mainstream kernel and zen).
After that I’ve set my resolution with ArandR and saved the file as monitor.sh since the endavouros default script calls it upon login to manually set the resolution/screen parameters.

After that I’ve solved all my issues and I’m currently running i3 with zen kernel.

2 Likes

there few thing that can try like " logind-check-graphical=true " that inside lightdm.conf or debug lightdm test mode .

try Lts 1st that seem fix for most people

Fixed it by @Dev0ut suggestion to install lts kernel. Working perfectly fine now.
Thank you for help

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.