Brother MFC-L2700DW

I have a packaged Debian driver for this printer. Someone on this site was kind enough to package it for me. It worked fine but it seems every time the upstream does it’s monthly upgrade at Arch, something changes where CUPS will not connect to the printer. (Network Printer) I stumbled across the fix for it but never marked it and can’t remember what it was. Anyone have any idea what needs to be done? Presently it will not work on Endevour. Thank you in advance.

It looks like there are PKGBUILDs created in 2021 in the AUR

Yeah I tried that but it returns with errors and won’t install,

Check the status of cups in systemctl

sudo systemctl status cups

If it is disabled for some reason then

sudo systemctl enable cups

and reboot.

If that is not the problem, at least we eliminated one suspect.


Did you try the cups version?

[eddbee@archlinux ~]$ sudo systemctl status cups
[sudo] password for eddbee:
● cups.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor pres>
Active: active (running) since Sun 2022-01-30 18:44:29 EST; 38min ago
TriggeredBy: ● cups.socket
● cups.path
Docs: man:cupsd(8)
Main PID: 366 (cupsd)
Status: “Scheduler is running…”
Tasks: 2 (limit: 9308)
Memory: 6.9M
CPU: 53ms
CGroup: /system.slice/cups.service
└─366 /usr/bin/cupsd -l

Jan 30 18:44:28 archlinux systemd[1]: Starting CUPS Scheduler…
Jan 30 18:44:29 archlinux systemd[1]: Started CUPS Scheduler.
lines 1-16/16 (END)

I have this printer (and several other Brother laser printers that are similar). I use the lpr and cupswrapper drivers from the AUR, also I have to manually add the printers in the CUPS web administration page or they will not work at all. I need to use the IP address when adding them, not the dnnsd:// that cups assigns them by default.

Most newer Brother Network Printers can be set up driverless after you enable local hostname resolution ( Troubleshooting: Network printer not reachable on the wiki).