Brother mfc j430w printer not working

I have a Brother printer Mfc j430W installed in wifi mode when I try to print it keeps saying could not start printer. In the printer block it says generic printer it does recognize at all my printer any help Please, how do you install my Brother printer Mfc j430W ?

Welcome! :smile:

Have you installed the driver and rebooted:

yay -S brother-mfc-j430w

giuseppe@giuseppe-tobefilledbyoem ~]$ yay -S brother-mfc-j430w
:: Checking for conflicts…
:: Checking for inner conflicts…
[Aur:2] lib32-glib-1.2.10-3 brother-mfc-j430w-3.0.1-3

2 lib32-glib (Build Files Exist)
1 brother-mfc-j430w (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
this is what comes out of my terminal when i done: yay -S brother-mfc-j430w what command should I put in it says 123, 1-3,^4 ?

Just press enter.

I done all the process even rebooted but on libreoffice writer it still says generic printer in the box when i try to print it still says could not print please check your printer configuration any help please

Most likely because you are using wifi mode on the printer. Is it possible to connect it with usb?

Well I will try to connect it directly to the pc now I will let you know if it works

On wifi you would have to go into a browser and type http://localhost:631 Then you would have to designate the ip address in order for it to work. It is a little more complicated. You can try. Here is a video to run you through it.

Edit: Because on wifi it becomes a network printer.

I tryed to connect to http://localhost:631 impossible to reach to site any help why ?? now I have the printer connected directly via usb but is says generic printer

neric printer

If you click on the drop down list?

To go into http://localhost:631/ you have to enter root as the user name and your current password for root.

1 Like

Under print settings in the menu the printer has to be there or it isn’t installed.

Screenshot_20201010_160202

Edit: On usb you can go ito print settings and try to add it.

Make sure the printer is connected to USB and turned on.

If you installed the driver and the rebooted and it’s connected to usb and you turned the printer on it would automatically load the printer.

Connecting it wirelessly it becomes a network printer so you have to go into cups via http://localhost:631/ and add it as a network printer. The printer has to on and connected wirelessly to do this. You go ito cups and use root as the user name and your password.

The problem is that if i copy http://localhost:631 into my browser google chrome the link does not work also what do you mean drop down list ? no under printer settings uit says default printer: SGENPRT

The link does work. it should open another box where you put in the user name as root and your password.

If it is not working in Chrome do you have Firefox?

Please look what happens when I try to copy into my goole chrome browser the link even with firefox the same problem

Please use Firefox and it will work.

I even tryed with firefox the same problem unable to connect