BrosTrend AX1800 USB WiFi 6

I have a BrosTrend AX1800 USB WiFi 6 adapter. It was working with the rtl88x2bu-dkms-git package until I ran updates on Friday. Since then, I have been unable to get it to fire up again.

I’m a long time linux user with Ubuntu being my daily driver for quite some time. I switched to Manjaro a couple of years ago and am now giving EndeavourOS a go. While many things in Linux are second nature, kernel mod troubleshooting has been rare for me. Pointing me in a direction to educate myself is always appreciated.

I tried uninstalling/reinstalling the package rtl88x2bu-dkms-git

I also tried a different package as a bit of research indicated this is a RTL8832AU chipset. rtl8852au-dkms-git seemed like a better math but, that did not get it going and the other did work at one point so I went back to it. Once I learn how to troubleshoot this, I may go and give this one a try.

A few commands I gleaned from another post on rtl88x2bu-dkms-git …

inxi -Fxxxaz … I’m not familiar with this one but, I’m going to do some learning once i get this back up and running. I’m extracting just the important parts. Let me know if something I left out was important.

  Kernel: 6.7.0-arch3-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: initrd=\084105a48cd641e0b415dee7334fbecf\6.7.0-arch3-1\initrd
    nvme_load=YES nowatchdog rw
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek 802.11ac WLAN Adapter driver: N/A type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:2 chip-ID: 0bda:b832
    class-ID: 0000 serial: <filter>
  IF-ID-1: enp0s20u3 state: up speed: 425 Mbps duplex: half mac: <filter>

Device-2 above is my adapter.


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0a5c:21e8 Broadcom Corp. BCM20702A0 Bluetooth 4.0
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 0bda:b832 Realtek Semiconductor Corp. 802.11ac WLAN Adapter
Bus 003 Device 005: ID 18d1:4eeb Google Inc. Pixel 7
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 003 Device 002

Modprob … this uses DKMS. I had to look up what that meant. I’m uncertain if modprobe even applies here.

sudo modprobe rtl88x2bu
modprobe: FATAL: Module rtl88x2bu not found in directory /lib/modules/6.7.0-arch3-1

I noticed this command when the install was going on. Thought I’d see what the results where.

sudo dkms install --no-depmod rtl88x2bu/5.13.1.r191.980d7cc -k 6.7.0-arch3-1                                                 ─╯
Module rtl88x2bu/5.13.1.r191.980d7cc already installed on kernel 6.7.0-arch3-1 (x86_64), skip. You may override by specifying --force.

Any information you can supply to help me learn what would need to be done after an update to get this working would be greatly appreciated.

What does this show?

lsusb | grep 0bda

Edit: From the id shown above it is a Realtek rtl8852bu

ID 0BDA:B832 - Default ID for USB Single-function, WiFi only

Have you tried this package?


I have not. I did notice that discrepancy when I was typing this up. I’ll give it a go.

1 Like

Dammit … spent all morning researching that and I was just using the wrong package. That package had been previously installed, too, so, it must have been the one that quit working after updating.

So then, is there a logical reason it would quit after updating? There was a kernel update as part of the packages I updated last Friday. Is there an additional step I need to take after a kernel update?

It could be that the package didn’t update properly with dkms when it rebuilds with a kernel update. Maybe I’m out to lunch on that but that’s my guess. :man_shrugging:

I always look at hardware in this way. You have to identify what chip it actually is in order to know if it’s a kernel module that runs it or if a package is needed to be installed in order for it to work. That’s just my thing. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.