Broken Update

After running pacman -Syu and rebooting my system no long boots, it gets this error

[OK] Finished File System Check on /dev/disk/by-uuid/F6C3-C06A. [ OK ] Finished Virtual Console Setup.
Mounting efi...
[FAILED] Failed to mount efi.
See 'systemctl status efi.mount' for details.
[DEPEND] Dependency failed for Local File Systems.
[ OK ] Started Network Time Synchronization.
[ OK ] Reached target System Time Set.
You are in emergency mode. After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, or "exit"
to continue bootup.
Give root password for maintenance
(or press Control-D to continue):

After giving the password and running systemctl status efi.mount

[root@bruno-nitroan51555 ``]# systemctl status efi.mount
x efi.nount - /efi
Loaded: loaded (/etc/fstab: generated)
Active: failed (Result: exit-code) since Sat 2023-12-02 10:50:59 UTC: 25s ago 
Where: /efi
What: /dev/disk/by-uuid/F6C3-C06A
Docs: man:fstab(5)
      man:systemd-fstab-generator (8)
CPU: 4ns
dez 02 10:50:59 bruno-nitroan51555 systemd[1]: Mounting /efi...
dez 02 18:58:59 bruno-nitroan51555 mount [688]: mount: efi: unknown filesystem type 'vfat'. 
dez 02 10:50:59 bruno-nitroan51555 mount [688]: dmesg (1) may have more information after failed mount system call. 
dez 02 10:50:59 bruno-nitroan51555 systemd[1]: efi.mount: Mount process exited, code=exited, status=32/n/a 
dez 02 10:50:59 bruno-nitroan51555 systemd[1]: efi.mount: Failed with result 'exit-code'.
dez 02 10:50:59 bruno-nitroan51555 systemd[1]: Failed to mount /efi. 
[root@bruno-nitroan51555 ``#

Everything that I tried here was giving me error, It had no access to the internet and I could not rollback the update, after some research I found out that the kernel was in conflict
running uname -r I get


after running pacman -Q linux I get

linux 6.6.3.arch1-1

I was able to boot with a live iso using the latest endeavouros and boot the broken ssd using chroot, I tried yay, pacman -Syu, pacman -S linux again, but as far as I know nothing happened. In a forum someone sugested mkinitcpio, but it gave an error

[root@bruno-nitroan51555 ~]# mkinitcpio
==> ERROR: /lib/modules/6.1.63-1-lts' is not a valid kernel module directory 
[root@bruno-nitroan51555 ~]#

I tried downgrading the kernel but I could not found the 6.1.63-1-lts to save my life.
I’m out of ideas

Things like this normally mean you need to relink to the correct efi file. Most machines allow you to do that from within your BIOS. Good luck.

EDIT: Perhaps you’ll find something helpful here:

filesystem not found is in most case caused by not working initrammfs images may an unfinished update with kernels involved…

you will need to rebuild initramfs images, depending on what you are using …
mkinitcpio is not used on newqer OS installs older will still use it…

In case you have older install (artemis) you need to run mkinitcpio -P in case newer OS install using dracut it will be different running reinstall-kernels when using systemd-boot and dracut-rebuild with grub bootloader.

pacman -Qs linux

I tried this solutions, but as a noob, I think I made everything worse.
I end up just reinstalling the system.

Thanks for your help guys!

We don’t use mkinitcpio. Did you install it? Did installing it ask you to remove other things?

Hello, you can try this solution: