Broken system and boot after system update (possibly nvidia-340xx-dkms)

I’ve used that driver for many years, sometimes it would break my system and sometimes it would not.
but i had stopped using it maybe for 6 months or a year ago either because sometimes it would not work or due to difficulty to get it installed. Years ago i used to like to have it installed due to screen tearing issues, but last time i installed endeavour os (that was a while back) the generic drivers worked fine to me and i had no screen tearing and compositing issues at all. I don’t do pc gaming (i am a console guy) so the generic drivers was enough for my needs.
The only reason i decided to try to nvidia drivers again is because i was having issues on a specific site and i was told the site needed the drivers of the GPU so i decided to give it a try to see if that would solve my bug problem there but it did not.
At the same time i can notice the improvement in performance with the nvidia drivers installed so that’s one reason to have it installed but i can realize it can be a pain to maintain it installed and working.
The recent patches to nvidia-340xx-dkms seems to get more hardcoded over time and with the potential to break your system, so much that i had problems to get compositing working back on plasma when i tried to remove that package.

1 Like

As @petsam said above. Otherwise run it on nouveau. You don’t have much choice as your hardware is outdated and not supported anymore by Nvidia.

I can use nouveau for now, from my experience uninstalling nvidia-340xx normally fixes a boot issue like this but have already done that and it’s still not booting into my desktop

Well normally installing something or uninstalling something does not cause any issues unless it was done wrong or there are leftover configurations that didn’t get cleaned out. Or some other reason currently unknown. :man_shrugging:

All you can do is try to remove all nividia drivers and install nouveau. Or follow what @petsam suggested.

1 Like

I still didn’t uninstall nvidia-340xx-utils, i can try that, can i install nouveau with a Non-graphical boot with systemd ?
and what would be the command to install nouveau ?

If you can boot and get into a tty you can.

1 Like

You can’t… or actually, you don’t need to. nouveau is in the kernel. When you correctly/completely uninstall nvidia drivers, nouveau will boot with modesetting (kernel embedded). There is also a package for nouveau, but it is just for completeness, not exactly needed, unless Archwiki says otherwise.

1 Like

I removed nvidia-340xx-utils and installed mesa and instead of getting stuck at the blackscreen with a flashing underscore this time i was stuck at the screen that says:

Starting version 250.5-1-arch
/dev/sda1 : clean …

I thought of running fsck -f to see if it would find anything wrong but it said it was already mounted and that there was a risk of breaking my file system if i continued so i said no (weird because i am used with fsck and i never get that warning)

What i did: i updated my system (including the kernel) and installed nvidia again and that worked, i got my desktop back with compositing and everything.

1 Like

Good program, fsck, warning you :slightly_smiling_face:. It should be run on an unmounted filesystem.

If you need to run it, do it in a live session.

On Archlinux? I doubt. :wink: Ubu/Deb habbits?

Miracles are for real after all!!!

1 Like

As long as it’s listed correctly you should be good.

inxi -Ga

Edit: I have never ever had to run fsck. I’m sure it’s set up to do this automatically on boot but it’s not something i would normally run unless i have a file system or drive problem.

1 Like
┌─<ramon @ ramon-m61pmes2p in ~>
└─<>──» inxi -Ga                                                                0 < 14:52:10
  Device-1: NVIDIA GT218 [GeForce 210] vendor: ZOTAC driver: nvidia
    v: 340.108 alternate: nouveau pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    bus-ID: 02:00.0 chip-ID: 10de:0a65 class-ID: 0300
  Device-2: Microsoft LifeCam Cinema type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-4:4 chip-ID: 045e:075d
    class-ID: 0102
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 92 s-size: 442x251mm (17.40x9.88")
    s-diag: 508mm (20.01")
  Monitor-1: VGA-0 res: 1600x900 hz: 60 dpi: 92
    size: 443x249mm (17.44x9.8") diag: 508mm (20.01") modes: N/A
  OpenGL: renderer: GeForce 210/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108
    direct render: Yes
┌─<ramon @ ramon-m61pmes2p in ~>

Welcome back @ramon395!


1 Like

I’ll try to always remove nvidia first whenever i get a linux kernel update, should have done that and i should have tried reinstalling nvidia since the beginning and i didn’t :man_facepalming: