Broken system and boot after system update (possibly nvidia-340xx-dkms)

First of all, it’s ramon395 here, i created this account because the update broke boot to me, i can only access my account with keepasscx, now i am aware that i can launch my database from mac or windows too but the problem is that i don’t have an alternative computer working here at home so i had to do this (i used the Live CD for this)
Any ideia on what to do or to fix the problem ? any suggestions
DE: Plasma

The first piece of important information would be what happens when you try to boot. What are you actually seeing?

A blackscreen and a flashing underscore at the top left corner of the windows

Could be graphics drivers.

Does ctrl+alt+f3 take you to a TTY?

You are right, could be the drivers for nvidia-340xx-dkms, i remember there was an update for the linux kernel and i should have unistalled the drivers first and install it after the update

Yes it does but then i realized my main account would not work because i am on Live CD, and i didn’t know how to leave that screen so i had to boot the live cd again

I mean will that key combination work from the flashing cursor, not the live CD.

I haven’t tried yet but will do
I just noticed someone left a comment on the nvidia package today:
Edit: i had the nvidia package installed when i updated my system and the first thing i did after realizing my boot was broken was to try to remove the nvidia package but my boot is still broken.

How did you remove it and did you also remove nvidia from the line modules=(nvidia) in mkinitcpio.conf?

If not use nano or vim, whatever you use: sudo nano /etc/mkinicpio.conf
save it and then type:

sudo mkinitcpio -p linux

then reboot.



I used the command bellow:

and used yay -R nvidia-340xx-dkms to unistall the drivers
Can i use the command i posted to edit mkinicpio.conf ?? i mean to get access to my user and edit that conf file from the terminal

Just enter the two pointers I gave you, your system is still set to search for the nvidia driver, which isn’t there anymore, hence the blinking cursor.

Ok makes sense, do i need to chroot on the Live Cd to do this ?

Yes, it is the easiest way in this case,. I guess.

Not sure what i am doing wrong, here’s what i tried and when i tried to open /etc/mkinicpio.conf the conf was empty:

[liveuser@eos-2021.12.17 ~]$ sudo mount /dev/sda2 /mnt
[liveuser@eos-2021.12.17 ~]$ sudo arch-chroot /mnt
mount: /mnt/proc: mount point does not exist.
==> ERROR: failed to setup chroot /mnt
[liveuser@eos-2021.12.17 ~]$ sudo mount /dev/sda1 /mnt
[liveuser@eos-2021.12.17 ~]$ sudo arch-chroot /mnt
[root@EndeavourOS /]# nano /etc/mkinicpio.conf
[root@EndeavourOS /]# ls
bin   dev  home  lib64	     media  opt   root	sbin  sys  usr
boot  etc  lib	 lost+found  mnt    proc  run	srv   tmp  var



It’s a typo.

1 Like

i opened that conf but it looks like it’s from the live cd and not from my user

If you chrooted into your install, shouldn’t it be from your install?

Yes it should

Try again, chroot surely did fail, perhaps another typo?

Could be

is there a way to copy the whole text content with nano so i can paste here ? i tried but i don’t have too much experience with nano


lsblk -f

so we can see you disk layout.

Indicate which partition is what.