Broken pipe error help

eos-update: package updater with additional features
Updating native and AUR apps...
[sudo] password for nate: 
:: Synchronising package databases...
 endeavouros            15.1 KiB   105 KiB/s 00:00 [----------------------] 100%
 core                  119.2 KiB  2.20 MiB/s 00:00 [----------------------] 100%
 extra                   7.9 MiB  62.0 MiB/s 00:00 [----------------------] 100%
 multilib              141.2 KiB  2.60 MiB/s 00:00 [----------------------] 100%
resolving dependencies...
looking for conflicting packages...

Package (1)             Old Version  New Version  Net Change  Download Size

core/archlinux-keyring  20240609-1   20240709-1     0.01 MiB       1.17 MiB

Total Download Size:   1.17 MiB
Total Installed Size:  1.67 MiB
Net Upgrade Size:      0.01 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 archlinux-keyrin...  1198.2 KiB  25.4 MiB/s 00:00 [----------------------] 100%
(1/1) checking keys in keyring                     [----------------------] 100%
(1/1) checking package integrity                   [----------------------] 100%
(1/1) loading package files                        [----------------------] 100%
(1/1) checking for file conflicts                  [----------------------] 100%
:: Processing package changes...
(1/1) upgrading archlinux-keyring                  [----------------------] 100%
==> Appending keys from archlinux.gpg...
==> Updating trust database...
gpg: next trustdb check due at 2024-11-09
:: Running post-transaction hooks...
(1/3) Reloading system manager configuration...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Checking which packages need to be rebuilt
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

warning: insufficient columns available for table display
Packages (19) electron30-30.2.0-1  electron31-31.2.0-1  eos-translations-24.7-1
              firefox-128.0-1  flac-1.4.3-2  gdbm-1.24-1  glib2-2.80.4-1
              glycin-1.0.1-2  hwdetect-2024.07.10.0706-1  libass-0.17.3-1
              linux-firmware-20240703.e94a2a3b-1
              linux-firmware-whence-20240703.e94a2a3b-1
              python-pydantic-2.8.2-1  python-pydantic-core-1:2.20.1-1
              qrencode-4.1.1-3  xcb-util-keysyms-0.4.1-5
              xcb-util-renderutil-0.3.10-2  xcb-util-wm-0.4.2-2
              xf86-input-libinput-1.4.0-2

Total Download Size:   446.79 MiB
Total Installed Size:  997.15 MiB
Net Upgrade Size:       -4.92 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 glib2-2.80.4-1-x...     4.9 MiB  24.3 MiB/s 00:00 [----------------------] 100%
 glycin-1.0.1-2-x...     3.3 MiB  29.2 MiB/s 00:00 [----------------------] 100%
 python-pydantic-...  1567.1 KiB  28.9 MiB/s 00:00 [----------------------] 100%
 python-pydantic-...   762.7 KiB  24.8 MiB/s 00:00 [----------------------] 100%
 flac-1.4.3-2-x86_64   322.7 KiB  24.2 MiB/s 00:00 [----------------------] 100%
 gdbm-1.24-1-x86_64    247.1 KiB  12.1 MiB/s 00:00 [----------------------] 100%
 libass-0.17.3-1-...   119.2 KiB  19.4 MiB/s 00:00 [----------------------] 100%
 eos-translations...    84.6 KiB   769 KiB/s 00:00 [----------------------] 100%
 xf86-input-libin...    41.1 KiB  5.73 MiB/s 00:00 [----------------------] 100%
 qrencode-4.1.1-3...    40.3 KiB  6.55 MiB/s 00:00 [----------------------] 100%
 linux-firmware-w...    35.0 KiB  2.14 MiB/s 00:00 [----------------------] 100%
 xcb-util-wm-0.4....    33.0 KiB  4.60 MiB/s 00:00 [----------------------] 100%
 xcb-util-renderu...     9.3 KiB   930 KiB/s 00:00 [----------------------] 100%
 xcb-util-keysyms...     7.5 KiB  1078 KiB/s 00:00 [----------------------] 100%
 hwdetect-2024.07...     5.7 KiB   814 KiB/s 00:00 [----------------------] 100%
 electron30-30.2....    66.8 MiB  33.2 MiB/s 00:02 [----------------------] 100%
 firefox-128.0-1-...    69.0 MiB  23.7 MiB/s 00:03 [----------------------] 100%
 electron31-31.2....    67.6 MiB  21.6 MiB/s 00:03 [----------------------] 100%
 linux-firmware-2...   232.0 MiB  55.9 MiB/s 00:04 [----------------------] 100%
 Total (19/19)         446.8 MiB   108 MiB/s 00:04 [----------------------] 100%
(19/19) checking keys in keyring                   [----------------------] 100%
(19/19) checking package integrity                 [----------------------] 100%
(19/19) loading package files                      [----------------------] 100%
(19/19) checking for file conflicts                [----------------------] 100%
:: Processing package changes...
( 1/19) upgrading flac                             [----------------------] 100%
( 2/19) upgrading glib2                            [----------------------] 100%
( 3/19) upgrading gdbm                             [----------------------] 100%
( 4/19) upgrading electron30                       [----------------------] 100%
( 5/19) upgrading electron31                       [----------------------] 100%
( 6/19) upgrading eos-translations                 [----------------------] 100%
( 7/19) upgrading libass                           [----------------------] 100%
( 8/19) upgrading firefox                          [----------------------] 100%
( 9/19) upgrading glycin                           [----------------------] 100%
(10/19) upgrading hwdetect                         [----------------------] 100%
(11/19) upgrading linux-firmware-whence            [----------------------] 100%
(12/19) upgrading linux-firmware                   [----------------------] 100%
(13/19) upgrading python-pydantic-core             [----------------------] 100%
(14/19) upgrading python-pydantic                  [----------------------] 100%
(15/19) upgrading qrencode                         [----------------------] 100%
(16/19) upgrading xcb-util-keysyms                 [----------------------] 100%
(17/19) upgrading xcb-util-renderutil              [----------------------] 100%
(18/19) upgrading xcb-util-wm                      [----------------------] 100%
(19/19) upgrading xf86-input-libinput              [----------------------] 100%
:: Running post-transaction hooks...
(1/7) Arming ConditionNeedsUpdate...
(2/7) Running kernel-install...
Running kernel-install for 6.9.8-arch1-1
dracut[I]: Executing: /usr/bin/dracut --no-hostonly --force /efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd-fallback 6.9.8-arch1-1
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-ask-password ***
dracut[I]: *** Including module: systemd-initrd ***
dracut[I]: *** Including module: systemd-journald ***
dracut[I]: *** Including module: systemd-modules-load ***
dracut[I]: *** Including module: systemd-sysctl ***
dracut[I]: *** Including module: systemd-sysusers ***
dracut[I]: *** Including module: systemd-tmpfiles ***
dracut[I]: *** Including module: systemd-udevd ***
dracut[I]: *** Including module: modsign ***
dracut[I]: *** Including module: i18n ***
dracut[I]: *** Including module: btrfs ***
dracut[I]: *** Including module: crypt ***
dracut[I]: *** Including module: dm ***
dracut[I]: *** Including module: kernel-modules ***
dracut[I]: *** Including module: kernel-modules-extra ***
dracut[I]: *** Including module: lvm ***
dracut[I]: *** Including module: mdraid ***
dracut[I]: *** Including module: nvdimm ***
dracut[I]: *** Including module: pcmcia ***
dracut[I]: *** Including module: qemu ***
dracut[I]: *** Including module: qemu-net ***
dracut[I]: *** Including module: systemd-cryptsetup ***
dracut[I]: *** Including module: fido2 ***
dracut[I]: *** Including module: pkcs11 ***
dracut[I]: *** Including module: lunmask ***
dracut[I]: *** Including module: resume ***
dracut[I]: *** Including module: rootfs-block ***
dracut[I]: *** Including module: terminfo ***
dracut[I]: *** Including module: udev-rules ***
dracut[I]: *** Including module: virtiofs ***
dracut[I]: *** Including module: dracut-systemd ***
dracut[I]: *** Including module: usrmount ***
dracut[I]: *** Including module: base ***
dracut[I]: *** Including module: fs-lib ***
dracut[I]: *** Including module: shutdown ***
dracut[I]: *** Including modules done ***
dracut[I]: *** Installing kernel module dependencies ***
dracut[I]: *** Installing kernel module dependencies done ***
dracut[I]: *** Resolving executable dependencies ***
dracut[I]: *** Resolving executable dependencies done ***
dracut[I]: *** Hardlinking files ***
dracut[I]: *** Hardlinking files done ***
dracut[I]: *** Generating early-microcode cpio image ***
dracut[I]: *** Constructing GenuineIntel.bin ***
dracut[I]: *** Store current command line parameters ***
dracut[I]: *** Stripping files ***
dracut[I]: *** Stripping files done ***
dracut[I]: *** Creating image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd-fallback' ***
dracut[I]: *** Creating initramfs image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd-fallback' done ***
dracut[I]: Executing: /usr/bin/dracut --hostonly --no-hostonly-cmdline -f /efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd 6.9.8-arch1-1
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-ask-password ***
dracut[I]: *** Including module: systemd-initrd ***
dracut[I]: *** Including module: systemd-journald ***
dracut[I]: *** Including module: systemd-modules-load ***
dracut[I]: *** Including module: systemd-sysctl ***
dracut[I]: *** Including module: systemd-sysusers ***
dracut[I]: *** Including module: systemd-tmpfiles ***
dracut[I]: *** Including module: systemd-udevd ***
dracut[I]: *** Including module: i18n ***
dracut[I]: *** Including module: kernel-modules ***
dracut[I]: *** Including module: kernel-modules-extra ***
dracut[I]: *** Including module: pcmcia ***
dracut[I]: *** Including module: rootfs-block ***
dracut[I]: *** Including module: terminfo ***
dracut[I]: *** Including module: udev-rules ***
dracut[I]: *** Including module: dracut-systemd ***
dracut[I]: *** Including module: usrmount ***
dracut[I]: *** Including module: base ***
dracut[I]: *** Including module: fs-lib ***
dracut[I]: *** Including module: shutdown ***
dracut[I]: *** Including modules done ***
dracut[I]: *** Installing kernel module dependencies ***
dracut[I]: *** Installing kernel module dependencies done ***
dracut[I]: *** Resolving executable dependencies ***
dracut[I]: *** Resolving executable dependencies done ***
dracut[I]: *** Hardlinking files ***
dracut[I]: *** Hardlinking files done ***
dracut[I]: *** Generating early-microcode cpio image ***
dracut[I]: *** Constructing GenuineIntel.bin ***
dracut[I]: *** Store current command line parameters ***
dracut[I]: *** Stripping files ***
dracut[I]: *** Stripping files done ***
dracut[I]: *** Creating image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd' ***
dracut[I]: *** Creating initramfs image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd' done ***
error: unable to write to pipe (Broken pipe)
(3/7) Check if user should be informed about rebooting after certain system package upgrades.
(4/7) Updating icon theme caches...
(5/7) Checking which packages need to be rebuilt
(6/7) Updating the info directory file...
(7/7) Updating the desktop file MIME type cache...
:: Searching AUR for updates...
 there is nothing to do

Press ENTER to close this window: 

i have been geting this broken pipe error when updating can i have some help please

i accidentally put the body text in the code segment sorry i have been up for 24 hours now

1 Like

Ah I see the issue here.

Step 1: Get some sleep! :sleeping_bed: :sweat_smile:

Sometimes inconsequential errors are thrown. Can I confirm with you (after step 1), are the updates actually failing to install?

the update installed just fine

You might try rebuilding the kernel images. If I’m not mistaken, the appropriate commands are:

If using systemd bootloader:

sudo reinstall-kernels

If using Grub bootloader:

sudo dracut-rebuild
[nate@nate-ms7d32 ~]$ sudo reinstall-kernels
[sudo] password for nate: 
Installing kernel 6.9.8-arch1-1
dracut[I]: Executing: /usr/bin/dracut --no-hostonly --force /efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd-fallback 6.9.8-arch1-1
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-ask-password ***
dracut[I]: *** Including module: systemd-initrd ***
dracut[I]: *** Including module: systemd-journald ***
dracut[I]: *** Including module: systemd-modules-load ***
dracut[I]: *** Including module: systemd-sysctl ***
dracut[I]: *** Including module: systemd-sysusers ***
dracut[I]: *** Including module: systemd-tmpfiles ***
dracut[I]: *** Including module: systemd-udevd ***
dracut[I]: *** Including module: modsign ***
dracut[I]: *** Including module: i18n ***
dracut[I]: *** Including module: btrfs ***
dracut[I]: *** Including module: crypt ***
dracut[I]: *** Including module: dm ***
dracut[I]: *** Including module: kernel-modules ***
dracut[I]: *** Including module: kernel-modules-extra ***
dracut[I]: *** Including module: lvm ***
dracut[I]: *** Including module: mdraid ***
dracut[I]: *** Including module: nvdimm ***
dracut[I]: *** Including module: pcmcia ***
dracut[I]: *** Including module: qemu ***
dracut[I]: *** Including module: qemu-net ***
dracut[I]: *** Including module: systemd-cryptsetup ***
dracut[I]: *** Including module: fido2 ***
dracut[I]: *** Including module: pkcs11 ***
dracut[I]: *** Including module: lunmask ***
dracut[I]: *** Including module: resume ***
dracut[I]: *** Including module: rootfs-block ***
dracut[I]: *** Including module: terminfo ***
dracut[I]: *** Including module: udev-rules ***
dracut[I]: *** Including module: virtiofs ***
dracut[I]: *** Including module: dracut-systemd ***
dracut[I]: *** Including module: usrmount ***
dracut[I]: *** Including module: base ***
dracut[I]: *** Including module: fs-lib ***
dracut[I]: *** Including module: shutdown ***
dracut[I]: *** Including modules done ***
dracut[I]: *** Installing kernel module dependencies ***
dracut[I]: *** Installing kernel module dependencies done ***
dracut[I]: *** Resolving executable dependencies ***
dracut[I]: *** Resolving executable dependencies done ***
dracut[I]: *** Hardlinking files ***
dracut[I]: *** Hardlinking files done ***
dracut[I]: *** Generating early-microcode cpio image ***
dracut[I]: *** Constructing GenuineIntel.bin ***
dracut[I]: *** Store current command line parameters ***
dracut[I]: *** Stripping files ***
dracut[I]: *** Stripping files done ***
dracut[I]: *** Creating image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd-fallback' ***
dracut[I]: *** Creating initramfs image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd-fallback' done ***
dracut[I]: Executing: /usr/bin/dracut --hostonly --no-hostonly-cmdline -f /efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd 6.9.8-arch1-1
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[E]: Module 'systemd-pcrphase' depends on 'tpm2-tss', which can't be installed
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-ask-password ***
dracut[I]: *** Including module: systemd-initrd ***
dracut[I]: *** Including module: systemd-journald ***
dracut[I]: *** Including module: systemd-modules-load ***
dracut[I]: *** Including module: systemd-sysctl ***
dracut[I]: *** Including module: systemd-sysusers ***
dracut[I]: *** Including module: systemd-tmpfiles ***
dracut[I]: *** Including module: systemd-udevd ***
dracut[I]: *** Including module: i18n ***
dracut[I]: *** Including module: kernel-modules ***
dracut[I]: *** Including module: kernel-modules-extra ***
dracut[I]: *** Including module: pcmcia ***
dracut[I]: *** Including module: rootfs-block ***
dracut[I]: *** Including module: terminfo ***
dracut[I]: *** Including module: udev-rules ***
dracut[I]: *** Including module: dracut-systemd ***
dracut[I]: *** Including module: usrmount ***
dracut[I]: *** Including module: base ***
dracut[I]: *** Including module: fs-lib ***
dracut[I]: *** Including module: shutdown ***
dracut[I]: *** Including modules done ***
dracut[I]: *** Installing kernel module dependencies ***
dracut[I]: *** Installing kernel module dependencies done ***
dracut[I]: *** Resolving executable dependencies ***
dracut[I]: *** Resolving executable dependencies done ***
dracut[I]: *** Hardlinking files ***
dracut[I]: *** Hardlinking files done ***
dracut[I]: *** Generating early-microcode cpio image ***
dracut[I]: *** Constructing GenuineIntel.bin ***
dracut[I]: *** Store current command line parameters ***
dracut[I]: *** Stripping files ***
dracut[I]: *** Stripping files done ***
dracut[I]: *** Creating image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd' ***
dracut[I]: *** Creating initramfs image file '/efi/4e0c728417a8480ea2b9a3ba49d56163/6.9.8-arch1-1/initrd' done ***
[nate@nate-ms7d32 ~]$

used the first command and this is what i got should i reboot

That didn’t throw that error, so that seems good :+1:

thank you

You’re welcome! Goodnight :wave: :wink:

This is harmless, it is not technically a error, it is described as one.
Funny thing is that this not always occur

@Dalto mentioned this in another thread that he fixed this in dracut but apparently this is not merged/implanted jet

1 Like