Broken colors on X11 KDE6

so i updated my system yesterday and switched to my work os, got back now to my main install and to my surprise colors on desktop, icons, system settings or any app that uses KDE graphics has incorrect shift colors (stuff that is supposed to be red was blue, brown tinged UI elements)

firefox, dolphin havent been affected by this issue, here’s a screenshot of how its looking

not sure what could’ve caused this issue, already tried resetting themes to the default one and rebooting, issues persists, its fixed once i go to wayland.

If you login as a new user does the same issue occur?

Are you using a colour management profile?

yes just tried, its not an user setting thing it seems, seems like last update broken something with x11

checked now and these were the packages upgraded on the last system update

[2024-07-02T00:06:46-0300] [ALPM] upgraded aha (0.5.1-2 → 0.5.1-3)
[2024-07-02T00:06:46-0300] [ALPM] upgraded alsa-card-profiles (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:46-0300] [ALPM] upgraded libldap (2.6.7-2 → 2.6.8-1)
[2024-07-02T00:06:46-0300] [ALPM] upgraded cifs-utils (7.0-3 → 7.0-4)
[2024-07-02T00:06:46-0300] [ALPM] upgraded dav1d (1.4.2-1 → 1.4.3-1)
[2024-07-02T00:06:46-0300] [ALPM] upgraded freetype2 (2.13.2-1 → 2.13.2-2)
[2024-07-02T00:06:46-0300] [ALPM] upgraded harfbuzz (8.5.0-1 → 9.0.0-1)
[2024-07-02T00:06:46-0300] [ALPM] upgraded libgcrypt (1.11.0-1 → 1.11.0-2)
[2024-07-02T00:06:46-0300] [ALPM] upgraded json-glib (1.8.0-1 → 1.8.0-2)
[2024-07-02T00:06:46-0300] [ALPM] upgraded discord-canary (0.0.438-1 → 0.0.441-1)
[2024-07-02T00:06:46-0300] [ALPM] upgraded libpipewire (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:46-0300] [ALPM] upgraded pipewire (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:47-0300] [ALPM] upgraded pipewire-audio (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:47-0300] [ALPM] upgraded libwireplumber (0.5.3-1 → 0.5.5-1)
[2024-07-02T00:06:47-0300] [ALPM] upgraded wireplumber (0.5.3-1 → 0.5.5-1)
[2024-07-02T00:06:47-0300] [ALPM] upgraded pipewire-jack (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:47-0300] [ALPM] upgraded libraw1394 (2.1.2-3 → 2.1.2-4)
[2024-07-02T00:06:47-0300] [ALPM] upgraded ffmpeg-git (7.1.r116058.g2902ed25b5-1 → 7.1.r116067.g5d54a25eea-1)
[2024-07-02T00:06:47-0300] [ALPM] upgraded miniupnpc (2.2.7-2 → 2.2.8-1)
[2024-07-02T00:06:47-0300] [ALPM] upgraded dolphin-emu-git (5.0.r21774.g10a95a4d-1 → 5.0.r21785.gf49659f-1)
[2024-07-02T00:06:47-0300] [ALPM] upgraded duckstation-git (0.1.6892.r47.gef69c31-1 → 0.1.6937.r61.g0c3cf1f-1)
[2024-07-02T00:06:47-0300] [ALPM] upgraded endeavouros-theming ( →
[2024-07-02T00:06:47-0300] [ALPM] upgraded libavif (1.0.4-3 → 1.0.4-4)
[2024-07-02T00:06:47-0300] [ALPM] upgraded harfbuzz-icu (8.5.0-1 → 9.0.0-1)
[2024-07-02T00:06:47-0300] [ALPM] upgraded eos-bash-shared (24.16.13-1 → 24.16.14-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded glances (4.0.8-2 → 4.1.1-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded gst-plugin-pipewire (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:48-0300] [ALPM] upgraded lib32-harfbuzz (8.5.0-1 → 9.0.0-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded lib32-libldap (2.6.7-1 → 2.6.8-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded lib32-libpipewire (1:1.0.7-1 → 1:1.2.0-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded lib32-pipewire (1:1.0.7-1 → 1:1.2.0-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded lib32-pipewire-jack (1:1.0.7-1 → 1:1.2.0-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded libadwaita (1:1.5.1-1 → 1:1.5.2-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded netpbm (10.86.41-1 → 10.86.42-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded libmediainfo (24.05-1 → 24.06-1)
[2024-07-02T00:06:48-0300] [ALPM] upgraded libqalculate (5.1.1-2 →
[2024-07-02T00:06:48-0300] [ALPM] upgraded libxnvctrl (550.78-1 → 555.58-1)
[2024-07-02T00:06:49-0300] [ALPM] upgraded linux (6.9.6.arch1-1 → 6.9.7.arch1-1)
[2024-07-02T00:06:51-0300] [ALPM] upgraded linux-headers (6.9.6.arch1-1 → 6.9.7.arch1-1)
[2024-07-02T00:06:52-0300] [ALPM] upgraded linux-lts (6.6.35-2 → 6.6.36-1)
[2024-07-02T00:06:54-0300] [ALPM] upgraded linux-lts-headers (6.6.35-2 → 6.6.36-1)
[2024-07-02T00:06:55-0300] [ALPM] upgraded linux-zen (6.9.6.zen1-1 → 6.9.7.zen1-1)
[2024-07-02T00:06:57-0300] [ALPM] upgraded linux-zen-headers (6.9.6.zen1-1 → 6.9.7.zen1-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded mame (0.266-1 → 0.267-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded mangohud-git (0.7.2.r24.g6c66565-1 → 0.7.2.r26.gc0afb84-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded mediainfo (24.05-1 → 24.06-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded noto-fonts (1:24.6.1-1 → 1:24.7.1-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded onetbb (2021.12.0-2 → 2021.13.0-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded openssh (9.7p1-2 → 9.8p1-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded perl-uri (5.21-1 → 5.28-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded perl-http-message (6.45-1 → 6.46-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded perl-libwww (6.72-1 → 6.77-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded perl-xml-parser (2.46-5 → 2.47-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded pipewire-alsa (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:58-0300] [ALPM] upgraded pipewire-pulse (1:1.0.7-2 → 1:1.2.0-2)
[2024-07-02T00:06:58-0300] [ALPM] upgraded protobuf (27.1-2 → 27.2-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded python-protobuf (27.1-2 → 27.2-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded python-pygments (2.17.2-3 → 2.18.0-1)
[2024-07-02T00:06:58-0300] [ALPM] upgraded sysfsutils (2.1.1-1 → 2.1.1-2)
[2024-07-02T00:06:58-0300] [ALPM] upgraded tk (8.6.14-3 → 8.6.14-4)
[2024-07-02T00:06:58-0300] [ALPM] upgraded twolame (0.4.0-3 → 0.4.0-4)
[2024-07-02T00:06:59-0300] [ALPM] upgraded wine-tkg-staging-fsync-git
[2024-07-02T00:07:00-0300] [ALPM] upgraded wlroots (0.17.3-2 → 0.17.4-1)

I haven’t used X11 for some months now, is there any particular reason you need to use it? If not I would just use Wayland but if there is hopefully someone can help you.

i don’t see how using a color profile, no matter how wrong, would invert colors, either way i tried that already.

i’m sorry but i’m not going to entertain that, not helpful or really relevant to my issue.
thanks for the previous suggestion on trying adding another user tho.

Your description was a shift in colours, from cooler to warmer. That’s entirely within the realm of colour profiles.

Now if your colours are “inverted”, you mean like the light / dark theme has switched?

You may not see it as useful but KDE is in the process of switching to Wayland as default so I would expect to see more bugs like this going undetected under X11. Just saying and was only trying to help, so bye


again, liked i say on the post, something that was supposed to be red (that dead island 2 icon) is blue, no amount of bad calibration would cause that, its somewhat inverted rather obviously, and as i also mentioned, not all programs suffer from that, like firefox, when i use a color profile everything changes, not just one app… period.

i really don’t think that line of thinking is compatible with the linux philosophy as i’m used to, if something has broken you just switch to something else… no on the contrary, you try to find the issue and fix it.

i’m not going to try and explain why i’m using X11 instead of wayland because i’m trying to figure it out one broken update… for the love of god.

As he said, it was just a suggestion. Anyway, good luck with it :wave:

1 Like

As I said Bye, not explaining my reasoning. Hope you solve your issue. Muting thread now.

1 Like

Well, I don’t see anything related to kde in your upgrade list. If you downgrade all packages to the version they were at yesterday. Does that work?

yeah i noticed that too, i just assumed it was kde related… i couldn’t find backups for all of them unfortunately, no idea on what is causing this

never mind… last thing i assume was that mesa was the culprit, which it is… im going to find which commit broke it, thanks for all the replies.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.