Broken Budgie

Hi, I’ve been a happy Budgie user 2 years and never had a single bug.
Suddenly, today as I log into Budgie, I can see my desktop for a second or two, then it switches to a grey screen with a sad smiley saying:
“Oh no! Something has gone wrong.
A problem has occured and the system can’t recover.
Please log out and try again”

  1. I could log in into Kodi DE (the only alternative DE I had)
  2. using Ctrl+Alt+F2 I switched to terminal, installed Gnome
  3. Gnome is working perfectly fine
  4. I remove Budgie-desktop and Budgie-extras (pacman -Rs)
  5. I rebooted my laptop and installed Budgie-desktopand Budgie-extras again
    But I still get the same error when I try to log into Budgie.
    Gnome DE is working fine.

Is there a way I can repair my Budgie DE? I really love it.
Apologies, if a similar topic exists,I searched and couldn’t fine.

Thank you so much in advance!!!

Is it the same as this?


Hi, I saw this thread earlier today:

See if your issue is also related to update to the package mentioned.

Edit: @xircon beat me to it.


1 Like

It has worked! Downgrading the package was the solution!!!

1 Like

I’m in the same boat. I just updated my machine a couple minutes ago. I get a login prompt, I enter my password. My Budgie desktop wallpaper pops up and as soon as my panel appears, I get the gray error screen.

I rebooted and loaded my pre-update snapshot (running snapper & BTRFS) to come here to see if this was a known issue.

I just want to confirm that libxfce-4windowing was the only package that needs to be unwound.


1 Like

Hi Snazzy,
Yes, it was the only package I had to downgrade. Everything works fine.

Thank you so much!

A new version of the package has just been released. libxfce4windowing 4.19.3-2
The upgrade went fine for me, no issues.


I just updated my “broken” Budgie snapshot and everything went smoothly. It’s now safe to update Budgie installs.

Thanks to everyone involved who made this correction so quickly.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.