Broke my SDDM, tty wont login

I have been having issues with desktop widgets on KDE. I found a guide that promised to fix this problem by editing “etc/sddm.conf.d/kde_settings.conf”. I put my username in the user field as the guide said, but I typed it in wrong by accident. Now upon login I am greeted with a black screen with only my cursor visible. I tried using tty to login and edit the file to fix this, but after successfuly logging in it goes back to the log in screen again. I also tried the systemd emergency repair mode, but it flat out said my password is incorrect.
Is there another way to access the file with elevated privileges and fix it?

You’ll probably need to chroot and edit the file.

As an optional quality of life experiment while you’re tinkering, you can set sddm to not automatically start (leaving you at a console/terminal).
systemctl disable sddm

You can start for testing with ‘systemctl start sddm’
Renable when fixed with enable instead of disable.

This may be helpful…it was to me last time I tried to get sddm to do something different. It’s very strict with no warnings/errors more or less, it’s right or it’s wrong.

In my opinion, chroot is not necessary.

Boot the system with a live USB and undo the changes you made to the SDDM configuration file.
Then restart.