Broadcom BCM43224 Slow Speeds

Hey everyone,

I just installed EndeavourOS on my 2011 MacBook Air, which has the Broadcom BCM43224 Wifi chip. The broadcom-wl driver was installed by default, and my Wifi connection does indeed work. However, the problem is my connection speed is a fraction of what it should be. My speed tests see no higher than 20mbps and I have a 300mbps connection.

In terminal when I run:
lspci -k

I see the following:
Kernel driver in use: wl
Kernel modules: bcma, wl

After scouring the forums here and Googling until my wits ends I tried the following:

Installed the DKMS driver:
pacman -S broadcom-wl-dkms

After reboot, no change in Wifi connection speed.

I also tried blacklisting the bcma module in etc/modprobe.d/blacklist.conf
I added an entry as:
blacklist bcma

I know for sure this is a Broadcom issue, as I have had similar problems with Ubuntu and Fedora, but I am new to all things Arch-based, and I just do not know what to do from here.

Anyone have some suggestions?

Hello @pegcitygeek
From what i have looked at this particular broadcom chips is a little troublesome. I take it you are not having an issue with connecting but mainly the speed? This chip does have issues on the 5 Ghz so it may work better strictly on 2.4 Ghz. I’m not sure what your equipment is and what you are using. I would blacklist all of the other broadcom.

blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma

Supposedly this chip is supported by brmsmac or brmfmac but i can’t say for sure. I’m just looking at specs from the Linux wireless site.

You are using the best option as far as I’m concerned broadcom-wl-dkms as it more recent.
You may be able to tweak router settings that may help. I have broadcom myself but it is really new and is in a desktop. It is an AC1900 dual band so it is quite good. Sorry i can’t be of more help.

Thanks for the help. For unrelated reasons I decided to go with the Clear Linux distro instead so I won’t be able to find a resolution for this post. However I will say that the same issue persists on CL as well, so I know for sure it’s purely a Broadcom issue.

It’s just one of those chips that i think is the same no matter what you run it on. :neutral_face:

brcmfmac supports newer chipsets, and supports AP mode, P2P mode, or hardware encryption.
brcmsmac only supports old chipsets like BCM4313, BCM43224, BCM43225.

According to linux wireless it say’s that chip is supported by both but who knows. I’m not suggesting it is i just see the info there.