Brightness reset always on boot

Since I discovered endeavouros I have never used another distro and have removed Windows from almost all my PCs!

Also I have never had any problems!

I have a pc (Samsung r519 fa04) where I decided to install endeavouros!

In this case I have only two small problems:

  1. Brightness reset on boot always
  2. Bright news and the colour slightly pale!

The first problem I can solve with xbacklight; the second with redshift!

But I wanted to ask if installing some particular driver (Libva Intel driver, vulkan Intel or intel media driver) could solve it?

Also, following the arch wiki, I can’t solve it by changing the kernel parameters or editing the file in etc/X11/xorg.conf.d/20-intel.conf.

I’m asking if I can do something for the pc in question (without having to use external programs like xbacklight and redshift)?

inxi -G

Graphics: Device-1: Intel Mobile 4 Series Integrated Graphics driver: i915 v: kernel
Device-2: Z-Star Micro Webcam SCB-0320N type: USB driver: ucvideo
Display: x11 server: X.Org 1.21.1.1 driver: loaded: Intel: unloaded:modesetting
Resolution: 1366x768
OpenGL: renderei: Mesa DRI Mobile Intel GM45 EXpress (ctg) v: 2.1 Mesa: 21.3.1

For things like display backlight it’s necessary to have the ACPI features being accessible for the kernel. And if neither the vendor provides them nor someone is keen enough to reverse engineer them you’re out of luck, I fear.

Personally, I’d consider xbacklight and redshift viable solutions. Is there anything not working for you with them?

There’s a systemd service that saves the backlight brightness. There may be several available depending on your hardware, you find out which are available using e.g.

systemctl list-units | grep backlight

Then, you can check on the status of that service, e.g.

systemctl status systemd-backlight@backlight:acpi_video0.service

This may give some information about whether the service is active or failing.

Next, there are various methods of setting the backlight, and therefore several kernel options to try. Some can work better than others:

https://wiki.archlinux.org/title/Backlight#Kernel_command-line_options

You can try each one in turn to see if it helps.

Do you have package xf86-video-intel installed?

Looks like it:

So definitely worth trying without.

systemctl list-units | grep backlight
sys-devices-pci0000:00-0000:00:02.0-backlight-acpi_video0.device loaded active plugged /sys/devices/pci0000:00/0000:00:02.0/backlight/acpi_video0
sys-devices-pci0000:00-0000:00:02.0-drm-card0-card0\x2dLVDS\x2d1-intel_backlight.device loaded active plugged /sys/devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight
systemd-backlight@backlight:acpi_video0.service loaded active exited Load/Save Screen Backlight Brightness of backlight:acpi_video0
systemd-backlight@backlight:intel_backlight.service loaded active exited Load/Save Screen Backlight Brightness of backlight:intel_backlight
system-systemd\x2dbacklight.slice

systemctl status systemd-backlight@backlight:acpi_video0.service
● systemd-backlight@backlight:acpi_video0.service - Load/Save Screen Backlight Brightness of backli>
Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
Active: active (exited) since Tue 2021-12-14 18:19:32 CET; 4min 21s ago
Docs: man:systemd-backlight@.service(8)
Process: 314 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:acpi_video0 (code=exit>
Main PID: 314 (code=exited, status=0/SUCCESS)
CPU: 10ms

systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0…
systemd[1]: Finished Load/Save Screen Backlight Brightness of backlight:acpi_video0.

yes, i have installed the package : xf86-video-intel

in relation to this: driver: loaded: Intel: unloaded:modesetting how i can ‘worth trying without’?

p.s I can turn down the brightness but it resets when I boot up.

with xbacklight and redshift I can solve but I wanted to know if I could with kernel modifications

also i tried the solutions of the arch wiki but without solving

acpi_backlight=video
acpi_backlight=vendor
acpi_backlight=native
acpi_backlight=none

not working

1 Like

There are two enabled services here, both trying to do the same thing.

So, option 1 is to remove xf86-video-intel (and reboot) and see if the modesetting driver works better (for many people it’s the better choice).

Option 2 is to mask one or the other backlight service (if one doesn’t work, unmask it and mask the other), e.g.:

sudo systemctl mask systemd-backlight@backlight:acpi_video0.service

Reboot and test,

sudo systemctl unmask systemd-backlight@backlight:acpi_video0.service
sudo systemctl mask systemd-backlight@backlight:intel_backlight.service

You should also read this wiki page to understand what each of these things mean:

https://wiki.archlinux.org/title/Backlight

Don’t simply copy-paste and expect the steps to work!

2 Likes

I tried them all and none of them worked!

I will continue with xbacklight and redshift